Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

yesterday I installed Windows 7 Ultimate x64. The problem is that I have some programs on the quicklaunch and I want some of them to be opened by hitting a shorcut key.

Well, the procedure to set it is very straightforward. Right click on the program shorcut, focus on Shorcut key field and press your desire shortcut. Apply/Ok. Done.

Well, it's not working. I've tried several keys combination, I've tred moving the shortcut to the desktop, my user folder, C:\ root, wherever. It simply doesn't want t work... While on XP this worked me just fine.

I've searched on google and I've found some people having the same problem, but I didn't found any solution to it.

Any idea?

If not, could you recommend a very lightweight macros program to set hotkeys to open apps and those sort of things?

Thanks!

share|improve this question
    
I've tried Ctrl+Alt, Ctrl+Shift, Ctrl+Alt+Shift, F1-F12... I forgot to say that the hotkeys HAS to be Ctrl+Alt+A/B/C/D or Ctrl+Alt+1/2/3/4 or Ctrl+Alt+F1/F2/F3/F4 becaue I have an IR remote controller which has 4 buttons that sends those keystrokes to the system. – emzero Mar 5 '10 at 17:45
up vote 1 down vote accepted

Was the keys working, any time after installing Windows 7? Check this forum and this forum. They mention corrupt user profile can also be a reason for this and some restriction for special keys also.

Make sure the actual shortcut is available in Desktop or startmenu hierarchy as this KB says.

As far as a mapper, you could try Hoekey or KeyTweak

share|improve this answer
    
I pinned the shortcut to the start menu and it seems to be working now. Thanks! – emzero Mar 5 '10 at 18:06

I had the same problem. I fixed it by:

  1. Deleting the non-functioning shortcut.
  2. Selecting "Send to..." on the target document and choosing Desktop.
  3. Opened properties on the newly created shortcut and setting the keyboard shortcut.

The first shortcut I created which didn't work was created in the same folder as the target and then moved the shortcut to the desktop. Why that didn't work eludes me but the 3 steps outlined above fixed the issue in my case.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .