Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a brand new 256GB SSD (Crucial CT256M225) which should have stellar performance. However, on my (also brand new) Dell Studio 1557 with Windows 7 Professional 64 bit, it's only giving a performance index of 5.9. I realise the performance index should be taken with a bit of a pinch of salt, but I wonder whether something's wrong. Given this paragraph from this MSDN article on Windows 7, I'd expect to see a high 6.X or possible a 7.X figure:

In Windows 7, there are new random read, random write and flush assessments. Better SSDs can score above 6.5 all the way to 7.9. To be included in that range, an SSD has to have outstanding random read rates and be resilient to flush and random write workloads.

In the Beta timeframe of Windows 7, there was a capping of scores at 1.9, 2.9 or the like if a disk (SSD or HDD) didn’t perform adequately when confronted with our random write and flush assessments. Feedback on this was pretty consistent, with most feeling the level of capping to be excessive. As a result, we now simply restrict SSDs with performance issues from joining the newly added 6.0+ and 7.0+ ranges. SSDs that are not solid performers across all assessments effectively get scored in a manner similar to what they would have been in Windows Vista, gaining no Win7 boost for great random read performance.

How can I diagnose any performance issues with either the disk or how Windows 7 is handling it?

Are there any particularly good tools you'd recommend?

One note of curiosity: I couldn't install the firmware update (to 1916) until I changed my BIOS handling of the drive to ATA mode; after installing the firmware I tried to boot the Windows installation DVD - but that only worked after turning it back to AHCI mode (which I've left it in).

Installing Windows 7 took longer than I expected - it sat at the "Windows is loading files" prompt for a very long time. Likewise it was on "Expanding files (0%)" for a long time. Since installation it's been fine though - but I don't know whether it's really providing quite as beefy performance as it should.

EDIT: My netbook with the 64GB equivalent drive has a performance index of 6.6...


Okay, so I've no idea what caused the change, but after trying loads of different things to work out what was wrong, I've rerun the WEI (about the 4th time in total) and the score has jumped to a far more respectable 7.3. I'm going to leave well alone now :)

share|improve this question
Maybe you overlooked the obvious: a fault in the drive? I've installed several SSD drives in Windows 7 (32 and 64 bit) and Mac OS, and never experienced anything like you describe. – Philippe Leybaert Mar 6 '10 at 12:42
FYI: my hard disk index is 7.6 on Windows 7 x64, using Corsair X256. – Philippe Leybaert Mar 6 '10 at 12:43
Did you install from scratch or move an image? Are you using windows or intel drivers? – Mikael Svenson Mar 6 '10 at 12:50
@Philippe: The idea of the disk being faulty had very definitely occurred to me. I'm hoping it's not the case... – Jon Skeet Mar 6 '10 at 12:58
Have you tried switching back to ATA now that windows is installed? It's a quick thing to test, maybe something funny with the controller in that laptop. I have a dell with an SSD here, access times are better in ATA mode for whatever reason, even though that shouldn't be true. – Nick Craver Mar 6 '10 at 13:10

I don't have a definitive answer for you, but:

  1. You definitely need to use AHCI with Windows 7.
  2. I have an older (and smaller, only 64GB) SSD from Crucial, it ranks 7.1.
  3. My intuition says that the fact the install was slow means something is wrong.

I would try downgrading the firmware to a prior version. if it doesn't help, perhaps the disk is faulty as @Philippe suggests.

share|improve this answer
I don't think it's the firmware version - the Windows installer took ages to get anywhere before updating the firmware. – Jon Skeet Mar 6 '10 at 12:58
oh. though you upgrade the firmware prior to installing Windows. I would guess it's a bad drive. – Shachar Mar 6 '10 at 13:20
Yes, I upgraded before installing Windows - but I tested whether I could get into the Windows installer before upgrading. – Jon Skeet Mar 6 '10 at 13:42

What about simple hard drive benchmarking tools? The manufacturer is going to advertise what their top speeds are for sequential/random read/writes. I would see how close you can get to hitting their numbers.

As soon as we got our Intel X25-M SSDs in at the office I ran HD Tune to get some performance benchmarks on them. The Intels we have advertise up to 250MB/second reads (I think) and I was able to peak our drives at around 200MB/s, so I figured they were working 'well-enough'. Also, Windows 7 x64 is running 'as-fast-as-we-expected-with-an-SSD' so we have no complaints so far.

Note: both drives are running with the firmware that came out of the box, as I am afraid to update it.

share|improve this answer
@Matthew: I ran HD Tune and saw about 150MBs steadily - again the manufacturer's specs say 250MB. I've no idea whether 150 is "close enough" for that or not. I may try running it on my other (non-SSD) laptop just for a point of comparison. – Jon Skeet Mar 6 '10 at 18:55
Just tried my "normal" hard disk - it's averaging about 40. That would be why it feels so slow then :) – Jon Skeet Mar 6 '10 at 18:57
@Jon: Maybe trying another bench can give futher insights ... e.g. . It's all German gibberish but it should boil down to download, extract and run it (not install required). Most users with SSD I know use this tool to compare their speeds. I'm not sure, have you activated the msahci driver? It gives a boost compared to the pciide one. – mark May 31 '10 at 21:47
@mfn: Sorry for the late response to this... where do I "activate" the msahci driver? – Jon Skeet Jun 18 '10 at 19:02
@Jon: First is hardware support trough the motherboard, most recent ones should have it. In Bios find Integrated Peripherals / ICH SATA Control Mode (or whatever it's named) and change IDE to AHCI. But watch out, Windows has the driver but maybe has not activated it, see . – mark Jun 20 '10 at 6:47

I had the same problem with Crucial SSD C300 on a Dell XPS 1645. Apparently the Dell BIOS is not adjusted for SSD use.

The solution is simple - you just have to install Microsoft .NET Framework 4 and Windows 7 will index the SSD with 7.7.

share|improve this answer
Hmm... I'm still getting 7.3. But maybe the bios will eventually be updated... – Jon Skeet Jun 18 '10 at 19:04
... although thinking about it, it may have been installing .NET 4 that took it from 5.9 to 7.3... – Jon Skeet Jun 18 '10 at 19:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .