Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to replace the default Tahoma font in Windows XP with the same font from Windows 7.

The reason is that Unicode symbols for the national alphabet I am using (Armenian) are awful in the Tahoma on Windows XP but fine in the one on Windows 7.

I have a custom WinForm application written in C# which uses national symbols from Tahoma on hundreds of screens and controls. It looks good when running in Windows 7 but ugly on Windows XP.

However, Windows XP does not allow replacing the font. It says that the font must be uninstalled before installing a new one with the same name, and of course does not allow uninstalling the default font.

How the replacement can be done? Please advise!

share|improve this question

migrated from stackoverflow.com Mar 6 '10 at 17:11

This question came from our site for professional and enthusiast programmers.

    
Hi, StackOverflow is dedicated to programming questions. As your question isn't programming related, it will probably be migrated to SuperUser.com which intended for general computer questions. –  Oded Mar 6 '10 at 14:08

5 Answers 5

It seems that no one ever actually answered the question you asked, instead trying to help you find an easier way to do what you wanted. If you do want to actually replace the Tahoma font from Windows XP with the one from Windows 7, read on.

You can do this with a Linux boot disk or WinPE, but there's also another way that doesn't involve booting another operating system. You must do all of this from an Administrator account.

  1. Make sure Tahoma is not in use by shutting down all programs. Right click on Desktop > Properties > Appearance tab > Click "Advanced" > Go through every item and if change all fonts to something besides Tahoma.
  2. Download a program called Unlocker. Google for it. When you install it, be sure to create a Start Menu group if asked.
  3. Go to Start > All Programs > Unlocker > Start Unlocker Assistant.
  4. Open the font folder for Windows XP (in Control Panel) and try to delete Tahoma (truetype). First you'll get an error message, but then you'll get the Unlocker window.
  5. In that window, click the drop down and select "Delete". You should get another dialog confirming the deletion.
  6. Repeat steps 4 and 5 for Tahoma Bold (truetype).
  7. Drag the Windows 7 font files (tahoma.ttf and tahomabd.ttf) into the Windows XP Fonts folder.
  8. Right Click on Desktop > Properties > Appearance tab > Click "Advanced" > Go through every item and change everything back to Tahoma.
  9. If the fonts appear blank, you may need to reset your font cache. Change the font back to something else, then wse the method in steps 4-5 to delete C:\WINDOWS\system32\FNTCACHE.DAT. After you restart your computer, repeat step 8.

If you would rather use a WinPE or Linux, do step 1, but replace steps 2-6 with using your boot disk to delete the font. You'll need to delete two files: tahoma.ttf and tahomabd.ttf from C:\WINDOWS\FONTS. To be safe, also go ahead and delete the file in step 9. Then boot back into Windows XP and follow steps 7 and 8. And, yes, step 7 must be done inside Windows XP--it will not work if you copy the files using any other operating system, as it won't actually install the font.

share|improve this answer

Right Click on Desktop > Properties > Appearance tab > Click "Advanced" > Go through every item and if available, change the font to your new font

On Vista, the the default font is called Segoe UI.

share|improve this answer
    
And it's definitely prettier :) –  Joey Mar 6 '10 at 17:40

Source

How to change Windows XP default system font

In Windows XP all it uses MS Sans Serif as the default font.Actually this is not a beautiful font when comparing other oses. Also they haven’t given any manual method to change the system default font. This font is identify by the system as MS Shell Dlg. But don’t worry, I will tell you a simple way to change the default system font Tutorial

  • go to start menu
  • click on “Run…”
  • Now type as “regedit” in the text box of Run dialog (see image as below)
  • Now click OK
  • you will see the windows registry editor
  • Now go as following
  • HKEY_LOCALMACHINE > SOFTWARE > Microsoft > Windows NT > Current Version > FontSubstitutes
  • After entering to the upper path you will see some font options
  • Find MS Shell Dlg and MS Shell Dlg2 from there
  • Now edit the default font value in those strings to your favorite font
  • Now all ok , restart your PC, and see
share|improve this answer

I just had the same problem and found a more technical but on the other hand way easier solution by doing the install manually...

Copy the new font files somewhere to your system (i.e. C:\Temp\)

Then use the command line (Windows-Explorer won't work here since it automatically starts the install routine) to copy the files to c:\Windows\Fonts under a different name:

copy c:\Temp\tahoma.ttf c:\Windows\Fonts\tahoma_0.ttf
copy c:\Temp\tahomabd.ttf c:\Windows\Fonts\tahomabd_0.ttf

After that use the Registry-Editor to redirect the font names to the new files:

Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts and find the entries Tahoma Regular (TrueType) and Tahoma Bold (TrueType) and change it's values from "tahoma.ttf" to "tahoma_0.ttf" and "tahomabd.ttf" to "tahomabd_0.ttf" respectively.

Now you only need to resart your system and then the new font files are used.

share|improve this answer

It won't replace as Tahoma is the default dont in WinXP so is always in use.

Reboot into Safe Mode and try replacing then. It may still not work as it may still be in use.

You could then try using something like BartPE to boot your PC and then try replacing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.