Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with my SSH session freezing predictably in less than minute. There is no warning, no errors, to way to get out of it. It doesn't seem to be a timeout issue since it happens when I'm in the middle of editing a file with vi (as an example).

Here's what I've tried:
1. Connect from home on Macbook ----> predictable freeze within a minute.
2. Connect from home on Ubuntu 9.10 server box ----> predictable freeze within a minute.
3. Connect from another network on same Macbook above ----> works fine.

It sounds to me like there must be something weird with my router or internet connection. But when this happens, I might also have a VPN connection up and an RDP session going, and both stay up and running. I would have then thought it was my webhost, but no one else is having any trouble (and it worked fine from another network).

Does anyone have any ideas?

share|improve this question

How's your router configured? Port forwarding? NAT?

share|improve this answer
    
It's basically just configured as a standard Linksys VPN router. I'm not doing any special port forwarding. – Donald Hughes Mar 7 '10 at 2:03
    
Is the router behind a DSL modem? Maybe you just need to disable NAT. – goblinbox Mar 7 '10 at 2:19
    
The router is behind a WISP antenna. But this is the side running the SSH client. The server is a web hosting provider. I don't believe I've ever needed to disable NAT from the client side to enable SSH. – Donald Hughes Mar 7 '10 at 4:58
up vote 0 down vote accepted

I resolved the problem by unplugging the Linksys WRV200 router and plugging in an old Linksys router I bought back in 2002. No more problems. If someone has any advice on what it is about that router (or a particular default setting) that would cause this problem I would love to hear it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .