Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using GRUB2 to dualboot Ubuntu and Windows 7. I installed Windows 7 some days ago and rewrote GRUB2 to cope with the dualboot. Everything went fine till yesterday - I could boot into both OS.

Since this morning my laptop restarts every time I choose Windows 7 from the menu. Ubuntu is still working. As I tried to mount the partition with Windows 7 on Ubuntu it gave me return code 2, so this isn't working as well.

I tried to reinstall GRUB2 to the MBR but it didn't help. I also tried to repair Windows 7 boot with it's install DVD, while trying so it showed me the following error: "Status: 0xc000000f Info: Boot selection failed because a required device is inaccessible."

Tanks in advance

share|improve this question

I had similar problem a few years back, solved it by starting ubuntu from the live CD, did a fresh install and that fixed the problem with the MBR partition. Then you can proceed to enter the windows CD and select repair fixing the Bootstrap of Windows OS. From then on every time you start you will get the menu option to select which OS you want.

If that menu does not appear enter again the ubuntu live CD start from there, restart and vuala! there they are.

Let me know if it dosent work out for u.

All the best

share|improve this answer
Kind of solved it yersterday by reinstalling Windows 7. Reinstalling the MBR via Windows DVD didn't help as well as reinstalling GRUB2 or switching to legacy GRUB. When I installed GRUB Windows 7 wasn't shown in the boot menu at all and so it went downwards from there. smartctl doesn't found errors on my HDD yet, so the problem may have been a coincidence. – Florian Pilz Mar 8 '10 at 9:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .