Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Red-hat 5.3

problem is that it is not showing graphical interface. only kernel / command prompt is available.

I tried startx, then I got this msg

No video BIOS modes for chosen depth

also showing that

ERROR: Failed to start X server.

What should I do?

share|improve this question
add comment

2 Answers

It's telling you that it cannot setup your video card for the resolution you've chosen. I would try running system-config-display as root, and failing that, I would go to IRC (Freenode) and lookup #redhat, explain the problem and let them talk you through the resolution.

share|improve this answer
    
I tried system-config-display ... Couldn't start X server with old config. Trying with fresh config...then it waits for some time and after that it shows.. Failed to start X server. –  Chankey Pathak Mar 7 '10 at 16:12
    
Then head over to #redhat on freenode and talk to them, it's realtime and they're exceedingly helpful. –  Richard June Mar 7 '10 at 16:27
    
Someone told me that Redhat doesn't work on Mercury's motherboards. Is it true? I have installed fedora 11 now and its working fine. –  Chankey Pathak Mar 9 '10 at 14:28
    
No clue, I've never tried one of Mercury's motherboards. Nor have I heard of any problems, though that's hardly definative. If fedora works, I would be inclined to believe that RH/CentOS 5.4 would work. –  Richard June Mar 9 '10 at 15:26
add comment
up vote 0 down vote accepted

The problem has been solved. Actually at the installation time it asks whether you want to install a basic server or want to include desktop and some other features. By default the BASIC SERVER option is marked and hence it doesn't include the graphical interface. I reinstalled with the Desktop option and it worked fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.