Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After installing VMware in Windows Vista or 7, there are two public networks that can't be identified, but upon further inspection are virtual networks created by VMware. The problem is when you're on a Home network, these "Unidentified Networks" are still there and mess up file sharing settings, among other things.

share|improve this question
    
I don't mind with the unidentified networks thingy but I don't like the fact that it messes with file sharing –  Jim Thio May 14 '12 at 7:23
add comment

2 Answers

up vote 14 down vote accepted

Per this site:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Click the follwoing subkey:

HKLM\SYSTEM\CurrentControlSet\Control\Class{4D36E972-E325-11CE-BFC1-08002BE10318}

  1. Browse through the 00xx subkeys until you find the REG_SZ VMNet subkey with a value of either “\DosDevices\VMnet8” or “\DosDevices\VMnet1” (default values)
  2. On the Edit menu, point to New, and then click DWORD Value.
  3. Type *NdisDeviceType, and then press Enter.
  4. On the Edit menu, click Modify.
  5. Type 1, and then click OK.
  6. Exit Registry Editor. 9 Disable & re-enable the VMWare NICs
  7. Log-out of your Windows account and log back in.
  8. Done

Or, optionally, use this powershell script to do the same thing automatically. This is most useful in Windows 7 which has PowerShell built in.

share|improve this answer
    
BTW, still coming back to this almost a year later as a reference every time I need to fix this on a new system / install of Vmware. :) –  matthews May 6 '10 at 3:19
    
+1 useful for me too. –  Jim Thio May 14 '12 at 7:44
add comment

Go to the Windows Firewall properties and disable the firewall for the VMWare adapter.

share|improve this answer
    
This seems like a good answer too. Does it work? I'll try :) –  Jim Thio May 14 '12 at 7:46
    
Can you provide steps for this? It's not clear. –  jocull Mar 19 at 19:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.