Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have never been able to get a clear answer on why the latest edition of iTunes does this:

I have my entire iTunes library located in C:\itunes\ and the library data files inside C:\itunes\!library_info for backup purposes. However when version 9 of iTunes came out it went from having iTunes as the title, to !library_info. Is there any way to get around this without moving my data files away? This is an annoying "feature" if that's what it is.

enter image description here

System information:

  • Windows Vista Ultimate 32-bit, latest updates
  • iTunes 9.0.3.15

I would be open to hacking the registry or doing a custom configuration of some sort. I don't want to move my library files out of itunes\!library_info to avoid them inter-mingling with my music library.

share|improve this question
    
Have you uninstalled and reinstalled iTunes yet? –  goblinbox Mar 12 '10 at 18:51
    
Yes, and scrubbed my directory with a restore from backup. Nothing is affected in a bad way, but just the title bar seems to be acting like it's a feature, not a bug >< –  Urda Mar 12 '10 at 18:59

4 Answers 4

I just had a similar experience, by moving all my iTunes files on my Mac onto my NAS, pointing the iTunes library on my PC to it, and noticed my iTunes title bar became I:/ (the network volume I mapped) on Windows.

I then did another move - created a folder called "Jeff's iTunes on NAS" on my NAS, moved all the iTunes files into it, and then specified the library again on my PC. This time it's showing the title I want.

I guess iTunes is simply using the parent folder name as its title bar content.

As for your remedy, I'd recommend you changing the folder name of your iTunes files, in order to make it whatever you want. Or, do just like what I did - create a subfolder under the folder that you don't want to move out, with the proper name, and move all the files inside.

share|improve this answer

I believe that iTunes expects the library files to be in C:\itunes\, and not in a sub folder. Your non-standard placement may be causing your symptoms? I suggest you report your issue to Apple on their iTunes Feedback page.

share|improve this answer
up vote 0 down vote accepted

Here is a detailed answer I got:

All of the folders in the iTunes 9 section appear in the iTunes folder along with all of the files that are listed below. If you want something other than iTunes to be displayed at the top of the iTunes window, you could rename the iTunes folder to something else (for example, I keep 4 different iTunes libraries on my external drive in separate folders called: Main Library, Gig Music, Jamey Aebersold, and Omnibook. These names appear at the top of the iTunes window.)

iTunes Folder

share|improve this answer
    
    
You can update your old library layout to use the new iTunes 9 layout. First open up this menu: flickr.com/photos/urda/4794010783 Then select the 'Upgrade to iTunes Media organization' option located here: flickr.com/photos/urda/4794010791 –  Urda Jul 14 '10 at 21:26

I do not use "add file to library" or "add folder to library"

Drag all the songs instead. Drag the songs you want to add from a folder to Itunes. Make sure you are on "Music" library instead of dragging it into a playlist.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.