Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I reboot my Vista machine it forgets the setting that I had for the default printer. I have tried setting more than one type of printer as the default and that doesn't appear to matter. It's simple enough to set the default printer again, but why is this happening?

share|improve this question
    
Just delete every printer except the one you want as the default. ;-) I've actually heard of this before. I've heard there is a registry fix for it but don't know it off the top of my head. –  Chris Thompson Jul 23 '09 at 20:05
    
Thank you for posting this question. This has been driving me nuts, and I was hoping Win7 would cure it, but it didn't. I was just about to ask this, did my duplicate search, and voila. –  John Rudy Sep 11 '09 at 15:31
add comment

2 Answers 2

What I found so far:

It will default to the first one it finds after logon, so in your case, I'm thinking the logon to the network is taking longer, therefore it finds the fax first.

Hopefully I can find you a work around, else you'll indeed have to delete other printers or life with it

Edit: Voila!

There are times when you want to change the default printer of a user or group of users without having access to the user's (or users') computer(s). You can do this by making a registry entry.

To change the default printer, add the registry entry as shown below:

WARNING: Using Registry Editor incorrectly can cause serious, system-wide problems that may require you to reinstall Windows NT to correct them. Microsoft cannot guarantee that any problems resulting from the use of Registry Editor can be solved. Use this tool at your own risk.

  • Start Registry Editor (Regedt32.exe).
  • Under the HKEY_ CURRENT_USER subtree, go to the following subkey:

Software\Microsoft\Windows NT\CurrentVersion\Windows

  • Add or edit the following registry entry

Device:REG_SZ:

where is the value that Print Manager would put in if this operation were done through Print Manager. It would resemble one of the following:

\SERVER\HPLASER,winspool,Ne00: or DESKJET,winspool,LPT1:

The Ne00 is a network port and LPT1 a local port.

With some applications, the default printer is read at the time the application is started and you will need to close and restart the application for the new default printer to show.

share|improve this answer
    
Thanks, I'll try this out. –  onedozenbagels Jul 29 '09 at 16:41
    
You rock. Thanks! –  John Rudy Sep 11 '09 at 15:32
add comment

I looked into internet postings on this subject and it appears that this is an uncorrected bug. I have exactly the same problem; I never connect remotely; I don't do any of the things the Microsoft people blame the problem on. For some software it still recognizes the list of printers, but requires you to choose; for others the software tells you no printer is installed at all. In all cases I have found the only thing to do is re-establish default printer at each reboot.

I suspect that there will never be a fix for this so get used to resetting default printer at each reboot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.