Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is a version of Windows XP: Can I paste plain text by default for Mac users. This drives me insane as well.

Whenever I cut and paste anything from one app to another in OS X it carries formatting with it. The only exception is when using a text editor like TextMate. I don't want text I copied from a website or Pages to paste with formatting in iChat, etc.

Does anyone know a way I can turn this off by default, or is there an app that will do it for me?

Thanks for your help.

share|improve this question
up vote 8 down vote accepted

Here you go: http://www.tuaw.com/2009/07/07/tuaw-tip-paste-without-formatting-by-default/

share|improve this answer
    
This worked great, thanks. Many a headache saved. – Darren Newton Jul 23 '09 at 20:28
2  
Be careful doing this. It breaks pasting into some text fields, like the subject of a Mail.app message. Learn to use the "Paste and Match Formatting" shortcut when you need to, instead. – Matthew Schinckel Jul 28 '09 at 14:18
    
Why the down vote, there is a note near the end of the post saying "Update: If you explicitly add ⌘-V in as a shortcut for Paste that's specific to iChat, you can restore the image paste capability without breaking the global shortcut." I assume you can do the same for Mail.app – Dan McClain Aug 6 '09 at 18:50

PTH Pasteboard gives you this functionality plus a whole lot more. Multiple clipboards, running scripts (python, ruby, bash, etc...) before being pasted, and persistent clipboard history across reboots are some of my favorite features.

I think I bought this utility faster than any other shareware ever, it's a steal at $25.

share|improve this answer
    
How exactly can you change this default in PTH Pasteboard? Thanks. – Peter Štibraný Apr 3 '12 at 13:49
    
OK, I've found it, but that's not really CMD+V paste :-( – Peter Štibraný Apr 3 '12 at 13:57
    
Goto PTH Pasteboard Preferences, Pasteboards tab, select Main from the source list on the left, and then check the "As Plaintext" checkbox. – Mark Thalman Apr 3 '12 at 15:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .