Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was given an illustrator file, but all the curves on the artwork are jagged. I've tried "rasterizing" and exporting by increasing the size of the image. I don't know what else to do or what I'm doing wrong.

My understanding is the beauty of Illustrator is that it's all done mathematically, so I can scale it up to infinity and it will be perfect (more or less). And that lines are drawn that way also, so they should be (or can be) infinitely smooth if they want to be.

Here's what I have right now:

sample

Here's what I have with the image selected showing the plot lines:

sample2

And a zoomed in view:

sample3

*I'm not experienced in Illustrator at all; I only know whatever I can carry over from moderate Photoshop experience.

share|improve this question

migrated from stackoverflow.com Mar 8 '10 at 5:46

This question came from our site for professional and enthusiast programmers.

    
Can you post a screenshot of your Layers toolbox? –  gabe Mar 7 '10 at 5:18
    
Impossible to say without seeing the objects that are there. This could be a document raster effects setting issue, or you could simply have a jagged bitmap graphic placed in the file. –  Hasaan Chop Mar 21 '10 at 22:45

6 Answers 6

up vote 2 down vote accepted

It's probably a raster image whereas the other is a vector image.

Here's a good quick explanation of the difference: Raster vs Vector

share|improve this answer
    
Hmm, interesting point. There are a ton of different layers they used. They appear to be for shading purposes. When I remove the shading, it appears smooth (for some of the parts I've tried). Still not sure what's happening or why. –  drewjoh Mar 7 '10 at 3:48
1  
Shaders are a raster effect--that is it has to rasterize the curves before applying it. That's why it appears "aliased" in the preview. In your preferences you should be able to choose the dpi of this rasterization. Higher dpi will create smoother curves but make rendering slower, which is why you usually work at a lower dpi (say 96, typical screen dpi) until exporting to a final rasterized product at a much higher dpi (600+). –  Plynx Mar 7 '10 at 7:54
    
BTW Illustrator is not my vector tool of choice, I'm speaking from general experience here. –  Plynx Mar 7 '10 at 7:55
    
Oh, I found something: help.adobe.com/en_US/Illustrator/14.0/… This should tell you all you need to know about where to go to set the resolution of any raster effects you have in your document. –  Plynx Mar 7 '10 at 8:06

Try, Edit > Preferences > General: Enable Anti aliasing

share|improve this answer
    
Yes, it is enabled in general preferences. I tried some other preferences too and nothing seems to affect it. –  drewjoh Mar 7 '10 at 3:37

I'm assuming you can open the file in Illustrator. When you zoom in, does it stay jaggedy? If you click on the jaggedy part, do you see lots of control handles? If so, it looks like someone traced a bitmap with too much precision.

If that's the case, see if they can trace the original raster image again. If not, try to use the "Smooth tool". Here's a reference: http://livedocs.adobe.com/en_US/Illustrator/13.0/help.html?content=WSCB13EA3D-2DAE-4a05-BB60-0FCA9907DDA9.html

EDIT: It looks like your Illustrator file still has the bitmap layer visible. You probably just need to make it invisible.

share|improve this answer
    
Yes, it stays jagged when zoomed in. I just added another image to show it. Thanks for your reference, going to read it right now. –  drewjoh Mar 7 '10 at 3:41

Is this a monitor-issue only, or can you print without visible pixels? To check this, try to scale the object in Illustrator and then print it.

If the print is pixeld, too, we can exclude any options that only handle with monitor representation.

share|improve this answer

Are there any filters applied to the shapes? Look in the Appearance palette. A filter will appear as an extra item in the list and that may be causing the jagged edges. Many filters need to perform raster operations which then creates the jagged edge on the shape.

If it is a filter, you have two options.

1) Disable/Delete the filter. Clicking on the eye next to the item in the appearance palette will disable the filter. This is the non-destructive approach and also allows you to test what is causing the issue.

2) Change the Document Raster Effects Settings. This can be found in the Effects menu and it allows you to control the resolution of any effects that are rendered in Illustrator.

share|improve this answer
  1. Perhaps you are in pixel preview mode? Make sure View>Pixel Preview is unchecked.

  2. Highlight the offending object and check the Appearances panel to see if there are any effects applied that might be the culprit.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.