Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

X11 on the Mac does a horrible job drawing fonts. I'm trying to use the GIMP and Inkscape and the menus, and other text, don't draw correctly half the time. What is the fix for this?

enter image description here

enter image description here

share|improve this question
    
I'm sure it's not helping you, but just in case: things are fine on my Mac, using XQuartz 2.3.4 (xorg-server 1.4.2-apple45). (I haven't used The Gimp since ages, but Inkscape looks okay, as do other X11 programs like Wireshark.) –  Arjan Mar 8 '10 at 6:54
    
I assume you're using XQuartz, not some other X11 software? –  Arjan Mar 8 '10 at 6:58
    
What is the default X11 that ships with Snow Leopard? At any rate, according to the Wiki (xquartz.macosforge.org/trac/wiki), I should be waiting for 2.4.1. –  anon Mar 8 '10 at 8:15

2 Answers 2

up vote 3 down vote accepted

I had a similar problem while using other X11 applications (wireshark), try to do the following :

  • Start X11 and open the Preferences
  • Output options tab, change the Colors to 'Millions'
  • Restart X11

The problem was that X11 was not able to antialias small sized font when the color depth was not big enough. Hope it will help !

share|improve this answer
    
That did the trick! –  anon Mar 11 '10 at 3:01

Try clearing Mac OS X's font cache. There are third-party tools to do this, but the easiest way is to reboot into Safe Mode by holding down the shift key at boot, and then rebooting again normally. One of the things Safe Mode does is delete the font cache.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.