Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The end goal here is that I am trying to install an Oracle 10g server on my Windows 7 x64 dev box. I use DHCP, and the Oracle installer is throwing up this warning:

Checking Network Configuration requirements ...
Check complete. The overall result of this check is: Failed <<<<
Problem: The install has detected that the primary IP address of the 
system is DHCP-assigned.
Recommendation: Oracle supports installations on systems with DHCP-assigned IP 
addresses; However, before you can do this, you must configure the Microsoft 
LoopBack Adapter to be the primary network adapter on the system.  See the 
Installation Guide for more details on installing the software on systems 
configured with DHCP.

I have installed the loopback adapter, but I am not sure how to make it the primary network adapter. I see this Microsoft KB article on the subject but it's Windows XP-oriented, and I can't seem to find a comparable one for Windows 7. Some of the options it talks about don't seem to be present in the views of the adapters that I see.

So, how can I make the loopback adapter become the primary adapter?

share|improve this question
add comment

3 Answers

up vote 16 down vote accepted

Open up your "Network and Sharing Center."

Click "Change Adapter Settings" in right-hand pane.

This should bring you to Control Panel\Network and Internet\Network Connections. You can also get there by running "ncpa.cpl".

Hit "ALT" to make the menu bar visible, and pick "Advanced" (Alt-N will bring you directly to that menu), and pick "Advanced Settings".

That will open the Advance Settings window, and you can adjust your binding order there.

share|improve this answer
    
Is there a way to automate this using netsh perhaps? –  CMCDragonkai Jun 16 at 2:09
add comment

None of the other answers at the time worked for me. I was using Windows 7 64bit, and simply changing the order of these adapters as mentioned by techie007 didn't work.

After some research, I found a method which worked for me:

  • Go to 'Network and Sharing Center' and then select 'Change adapter settings'.

  • Right click one of the network adapters you wish to change, and select 'properties'.

  • In the properties dialog, select 'Internet Protocol Version 4 (TCP/IPv4)' and then select 'properties'.

  • Select 'Advanced' on the next dialog.

  • Untick 'Automatic metric', and enter a number as the 'Interface metric', to order the network adapter.

Windows orders network adapters from low to high numbers (a network adapter with an interface metric of 1, would be preferred over one with a metric of 2).

share|improve this answer
add comment

This may not always be the case. The method does not list any hidden adapters which can be listed using IPconfig /all.

This would be the last crack in this case: http://blogs.msdn.com/b/sqlserverfaq/archive/2009/10/08/receive-a-warning-about-the-network-binding-order-on-the-setup-support-rules-page-when-install-sql-server-2008-in-a-failover-cluster.aspx

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.