Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am connecting to a remote suse 10.0 machine, and I do not get colors on the terminal, while I get them when I connect to a remote Ubuntu machine.

How can I do to get colors on the suse terminal?

share|improve this question

migrated from stackoverflow.com Mar 8 '10 at 16:57

This question came from our site for professional and enthusiast programmers.

4 Answers 4

up vote 2 down vote accepted

This depends on a couple of factors. What is the TERM set to when you login to the remote machine

ubuntu$ echo $TERM

If the terminal type is not set to a terminal capable of colour (i.e. dumb or vt100), then that would be your problem.

Otherwise I suspect you mean that Linux commands are not executing in colour mode by default. Try

ubuntu$ ls --color

Which you can fix by setting an alias in the user's shell start-up files. (E.g. .bashrc / .bash_profile for bash).

(And yes I spell colour with a 'u').

share|improve this answer

If you are using bash on the remote terminal, try this as a guide.

share|improve this answer

I'm very newbie on Linux but I know that I get colors when I log in as ROOT but no colors when I log in as me.

How are you loging in?

share|improve this answer

Try running this:

export TERM="linux"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.