Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed many things trying to make this modem works, until I finally found something that should work on the official website.

Now it isn't working, and I hope if I uninstall all other things and start a clean install again it will.

I have no idea where and how it was installed, and I don't remember anymore where I got all stuff and even if I did, I don't think they came with any uninstall method. So, anyone could tell me how I can clean up all that?

share|improve this question

2 Answers 2

Check this guide : Uninstalling Applications in Mac OS X and also try with this AppCleaner Uninstaller.

share|improve this answer
    
Thanks, I've tried AppCleaner, it's great stuff. I'll probably use it more. :) –  Cawas Mar 9 '10 at 1:06
up vote 1 down vote accepted

Well, I finally solved it.

First I tried using SuspiciousPackage, a great Quicklook plugin to show some selected details information about Packages. But that didn't help. Thanks to that I figured it might not be a problem of bad installation after all.

Then I decided to look at the Console for All Messages and started trying to diagnose it and understand what was going on. Searched on google for the error message "Connect: ppp0 <--> /dev/cu.HUAWEIMobile-Modem", found this great link and found a solution:

Create (or replace, I had no file tho) the file /etc/ppp/options with just these lines:

refuse-chap
refuse-mschap
refuse-mschap-v2

Then configure it properly on the Network Preferences pane and that's it! :)

I'm just posting this from my new connection!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.