Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Win 7 Pro x64 is unable to enter sleep mode.

Pressing the sleep button results in strange state where the computer starts entering the sleep mode, the display is turned off but then the whole process stops, it does not switch off the hdd, the keyboard still responds to numlock/capslock, but the display does not on anymore. I have to cut power and restart. If I remove everything (wireless mouse, external hdd, usb hub, etc.) it does enter sleep mode, but if there is something left, it does not, though every one of them has "Allow the computer to turn off this device..." checked and "Allow this device to wake the computer" unchecked.

Why does it not work? It was working properly in the RC.

share|improve this question

1 Answer 1

I had to resort to using a program called Sleep.exe to get sleep to work on my Windows 7 x64. Make sure to use it with the /f switch.

share|improve this answer
    
Though I'll definitely take a look at it, I'd rather have it working as it was meant to work (and as it was already working once). Using a program enter sleep mode is not a fix, it's a workaround. Win7 should be able to do that on its own. There is something out of order, that's obvious, and a workaround just hides it, it does not repair. Besides, it requires to push/click something instead of just closing the lid or pressing the sleep button and I really would not like to assign a global shortcut key to that function. But I'll keep that .exe as an emergency exit. Thanks for your suggestion. –  gemisigo Mar 9 '10 at 9:32
    
I totally agree, this should be working out of the box. However, after spending a god deal of time fiddling around with the power settings and following assorted guides on the net I finally gave up. –  CGA Mar 9 '10 at 11:20
    
I might just end up the same. That's a pity nobody knows the solution. –  gemisigo Mar 10 '10 at 19:20
    
I'll have to look for another solution. Tried the sleep.exe you suggested but it fails just the same way. –  gemisigo Mar 11 '10 at 20:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.