Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently I managed to completely mess up my ASUS 900, but I have no immediate desire to upgrade since it's only my travel laptop (and I'm waiting for a few months to see if anything interesting comes out). For now, though, I've hit an interesting problem. The 4GB SSD that is soldered onto the motherboard is broken.

Since it's soldered on, there's really no hope of replacing it (I believe), so I've been solely running off the 16GB that is inserted into the mini pci-e slot. But since it can't read from the SSD it keeps giving me an error every time it tries to boot and read the ssd. Is there any way to either force Ubuntu to not check the drives on boot or disable the drive altogether, so that I don't have to sit through a 5 minute boot process each time I want to use the computer?

share|improve this question
add comment

2 Answers

I was also having problems with the onboard SSD. Thinking it was broken. I got to this thread looking for a way to disable it. Even if I disabled the onboard SSD in the BIOS, Ubuntu sees it anyway. And so, I get those fatal errors.

Well... I found a way to bring the SSD back to life! Actually, it was this thread that helped: http://forum.eeeuser.com/viewtopic.php?id=78939 It's a thread full of others who got a broken SSD from Ubuntu 9.10.

The solution is to zero fill the SSD and start all over. As mentioned a couple of times in the thread, use dd:

dd if=/dev/zero of=/dev/sda bs=1M

Make sure you replace sda with the right device.

I just successfully installed Ubuntu 10.10 beta on the onboard SSD. Now I'm hoping this will bring the other SSD back to life as well, as it also died from installing Ubuntu 9.10.

share|improve this answer
    
Hmm, this would be excellent to test if only I could find my power adapter for it. Also, the battery life in it is dead. But hey, if I can make it work... –  ashays Sep 9 '10 at 13:15
add comment

I had a similar issue on my asus900.

It sounds like you need to change the boot options. While the machine is starting up, hit the f2 key when you see the grey "asus" screen. You should be able to set the card drive as your first priority to boot from. I recommend completely removing the broken drive from the list of boot drives.

share|improve this answer
    
Hmm, I went into the BIOS configuration and completely removed the "ASUS-PHISON OB SSD" from all parts, and it didn't seem to work. I even made it no longer the IDE Master in the advanced tab. I still seem to get Ubuntu trying to read from it from the start. –  ashays Mar 27 '10 at 17:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.