Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sound in Ubuntu, it has its own special joy. I would like my external microphone to work.

Symptoms:

  • I can play sound through the speakers
  • I can play sound through the headsets.
  • Plugging and and plugging headphone output correctly switches.
  • I can record from the built-in microphone, using "Sound Recorder" and others.

but:

  • I cannot record from the external microphone.
  • My Sound Preferences/Input panel has no option for an external microphone.

If the answer is upgrade the ALSA drivers, please say exactly what to type.

Thank you.

========

I'm using Ubuntu 9.10 Karmic Koala on a laptop (Gateway W3501), Sigmatel.

That is:

~$ head -1 /proc/asound/card0/code*
==> /proc/asound/card0/codec#0 <==
Codec: SigmaTel STAC9205

==> /proc/asound/card0/codec#1 <==
Codec: Conexant ID 2c06
~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

First, I looked at the ALSA website, because the sound drivers ship out of sync with the usual Ubuntu upgrades. For Intel HDA especially, the recommendation is to install alsamixer and then go playing with settings.

$ sudo apt-get install alsamixer
$ alsamixer

Then I found that the default settings for "Digital Input Source" is incorrect. It should be "Analog".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.