Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been having a recurring kernel panic with my Ubuntu 9.04 installation (see other posts by me).

Today, I was fiddling around trying to get some cable attached when the system panicked. Looking at the layout, the only cable in the vicinity was the network cable. Upon further investigation, it seems that the system reliably panics whenever I insert a network cable. Removing the cable does not cause the panic.

How do I stop the system panicking when I insert the network cable?

If more information is needed, please add comments/answers and I'll post the required data.

Edit

Using the TTY view (Ctrl-Alt-F1), inserting the cable generates the same output as before, however, as it's only 40 lines it's not much help and I've not found a way to capture the output to a file. rlogin obviously won't work.

My next step will be to try a different cable and then, if the problem persists, a new network card.

share|improve this question
add comment

3 Answers

Chances are that there is a problem with the network hardware or possibly the driver running it. By inserting the cable, it activates the link, which will trigger several software processes.

To be doubly sure, check the console output when you insert the cable to see if anything borks out before the kernel panic.

You can try using a different network card to see if the problem goes away. If it turns out to be a driver problem, using a different version of the kernel or building your own stock kernel might solve the problem.

share|improve this answer
    
Definitely check the console output to see what happens. –  emgee Mar 9 '10 at 2:52
    
By console, do you mean the Ctrl-Alt-F1 (I think that's the key-combo) terminal? Can you get this output elsewhere as 40 lines probably won't be enough. –  Skizz Mar 9 '10 at 11:27
    
40 lines will be enough because you are only interested in the last few lines where you inserted the cable. Otherwise, you can find a copy of the information in a number of files such as /var/log/dmesg and others in there. –  sybreon Mar 16 '10 at 1:14
add comment

It is most likely hardware problem. Either your network card or your motherboard is dying. It might be also possible that cable is damaged or equipment on the other side of a cable is faulty.

I've seen similar problem in real life and it turned out to be motherboard problem, capacitors there have started to give up.

share|improve this answer
add comment

You could try a live CD for an OS that uses a different network stack. Like OpenSolaris or a BSD variant. Obviously this won't solve your problem but it would help narrow down whether it's hardware or software.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.