Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My network shares were mounting fine yesterday.. suddenly they are not. They were mounting fine for the last two weeks or however long since I added them.

When I run sudo mount -a I get the following error:

topsy@monolyth:~$ sudo mount -a

mount error(12): Cannot allocate memory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(12): Cannot allocate memory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(12): Cannot allocate memory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(12): Cannot allocate memory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
topsy@monolyth:~$ 

I followed this guide when setting them up: http://ubuntuforums.org/showthread.php?t=288534

So I tried removing them by doing the reverse, and then rebooting, then adding them again and rebooting.

Problem persists.

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

Are you mounting windows shares? If so, this could be your problem:

http://linux.derkeiler.com/Newsgroups/comp.os.linux.networking/2006-10/msg00629.html

share|improve this answer
    
Indeed, it was. –  Alex Mar 10 '10 at 20:12
    
Could also indicate that your drive is out of space that you are attempting to mount. –  Martin Murphy Dec 7 '11 at 19:03
    
Is it possible to work this around on the Linux side? I have no access to the Windows box... Connecting from Windows is fine. –  Calmarius Apr 8 '13 at 10:25
add comment

Since it's always nice to have the text (since the link may become invalid), here's the solution the link in the accepted answer points to:

The Windows Fix, A.K.A.

The Solution!

Check the Event Log on the Windows machine that fails to allow it's share to be mounted under System. Look for a red X, and the word Error. The Source is Srv. The error will be:

The server's configuration parameter "irpstacksize" is too small for the server to use a local device. Please increase the value of this parameter.

If you have this error on the Windows machine that fails to have it's share mounted, then do the following...

This key in the system registry must be modifed or created:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer \Parameters\IRPStackSize

If the key is there, increase it a bit to say 15 or 18. If the key does not exist, as in my case, create a new DWORD Valute. Name it IRPStackSize. Double click on it to edit the value, put a check on the Decimal radio button for the Base so that you can see the parameter value as a decimal value and not a hexidecimal value. Give the new key a value of 15 and reboot. If that is not enough, raise it a litte to let's say 18 and then reboot again. The problem is solved. Go mount your samba shares.

share|improve this answer
    
I wonder what's up with this, it randomly started happening to me as well and the above fix worked. I wonder what the root of the issue is... –  Kirk Jan 10 '11 at 6:29
add comment

Another possible cause for the mount error(12): Cannot allocate memory problem is that the windows share permissions are not set up properly. Not only do you need to have the appropriate permissions set up on the directory you are sharing, but the account you are using to access the share needs read permissions under Sharing->Permissions.

share|improve this answer
add comment

If you're exporting from Windows 7 , there are two (different) registry keys involved (link still good).

http://alan.lamielle.net/2009/09/03/windows-7-nonpaged-pool-srv-error-2017

share|improve this answer
    
Unfortunately the link is gone. Do you remember which ones? I suppose, these are something mentioned here: 241931348f64b1d1.wordpress.com/2010/07/14/… –  dma_k Aug 13 '11 at 22:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.