Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up a development environment in a virtual machine on my laptop, with debian os. I have both lan and wlan available on the host machine, yet I can't connect to the internet using either.

As I said the host OS is windows XP and the guest OS will be the latest Debian, we downloaded the business card net install so we need internet access from the beginning, besides we need the virtual machine to be visible on the local network (for my fellow developers).

We tried host-only networking, NAT, bridging, with proxy (the local network uses a proxy to connect to the internet) and without proxy, nothing seems to work. What else can we do?

Thanks a lot.

share|improve this question
up vote 0 down vote accepted

The option that you want is bridging, which will put the VM on the same subnet as the host. NAT would put it on a different subnet, but should still allow you to reach the internet.

Okay, one thing that I've run into with VirtualBox is that sometimes the VM description file becomes corrupted, and something stops working, such as the virtual NIC. The fix (for me) has always been to just create a new VM, which creates a fresh description file for that new VM. If this happens after I have already installed the OS, I simply attach the virtual hard drive to the new VM, and all is well.

share|improve this answer
Thanks, I figured out that bridging would be what I'd need, but the problem was an entirely different one. The VM couldn't access the internet because the proxy was refusing authentication to the user registered on the VM box (it authenticates using active directory). In the end we discarded the idea of setting up a development VM and used one of our machines. Thanks anyway :) – user30614 Mar 10 '10 at 11:31

You should be able to use bridging to what you want. Does the vm actually get an IP address? I am guessing this is a problem with the setup of the guest rather than the virtualbox settings. You can use ifconfig to do this on the command line.

share|improve this answer

You must log in to answer this question.