Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to tinker with the Android software development kit, and I have found out that it only support 32-bit versions of the Java Platform and Eclipse.

I installed the ia32 Sun Java runtime environment and the 32-bit version of Eclipse. I also used the update-alternatives program to make a java 32-bit preference. Both of these seem to run fine. I also installed the Eclipse android plugins, but my problem lies in the SDK downloaded from Google. When I go to Eclipse preferences and try to tell it about my Android SDK location, there are no SDK targets listed.

Has anyone else gotten this running on Ubuntu 9.10 64-bit? Thanks.

share|improve this question

closed as too localized by Sathya Mar 23 '13 at 8:07

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
have you went into the Android SDK folder and run android.sh that will give you an option to download the targets? none come in the zip file with the SDK for the website –  Seth Hikari Aug 3 '11 at 23:46

4 Answers 4

Android SDK requires 32 bit libraries, but that are not include in 64bit version of Ubuntu by default.

Use this for finding dependencies

getlibs

share|improve this answer
    
Doesn't seem to work for me :( I tried it on ddms and ddms.jar and in both cases it said "Cannot determine the dependencies required by this program, it may be a script" –  Hamish Downer Mar 15 '10 at 14:28
    
Doesn't seem to work for me either. Every program I tried to run from the android SDK (that wasn't a script), it said all required libraries are already installed. –  user30667 Mar 16 '10 at 20:35

Other sources say you just have to have ia32-libs installed and you're away. The emulator worked for me without having to do anything else.

share|improve this answer
    
I have ia32-libs installed, and still no joy. –  user30667 Mar 16 '10 at 20:45
    
ia32-libs does not include gtk, which Eclipse requires. I suspect it's not possible to run 32-bit Eclipse on a 64-bit system. –  Edward Falk Dec 11 '10 at 17:40

Is there some reason you can't upgrade to Ubuntu 11.04, which is the latest stable release? In 11.04 the Android SDK just works..

share|improve this answer

Install the 32-bit libraries for the Android emulator (assuming yum is installed):

yum install glibc.i686 glibc-devel.i686 libstdc++.i686 zlib-devel.i686 ncurses-devel.i686 libX11-devel.i686 libXrender.i686 libXrandr.i686
share|improve this answer
2  
yum isn't a part of Ubuntu afaik –  Simon Sheehan Jan 29 '12 at 22:12