Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a way to make it very obvious that my VirtualBox window isn't in focus?

The problem I'm having is switching between workspaces on Ubuntu or OS X and then trying to type in my Windows virtual machine, only to find that it's not in focus. The Windows window looks like it's in focus (based on the title bar), but I'm actually typing in Firefox on the host machine, for example. It's even worse because the Windows text insertion cursor is blinking to show focus.

Ideally, I'd like the VM's display to get unsaturated (e.g. a "partial" grayscale) when not in focus, just to prevent this keyboard-focus problem. Other options would be fine too, as long as I don't have to second guess where my focus is.

I'm not using the seamless mode -- the display is all within a window.

share|improve this question
    
On Ubuntu, do you use Compiz Fusion? –  Phoshi Mar 10 '10 at 21:57
    
this has been driving me mad too... i just try to minimize the window fully out of habit –  WalterJ89 Mar 11 '10 at 10:53
    
What did you end up doing for this? –  MT. Apr 8 '10 at 21:52
    
@MT: It's still an open issue, unfortunately. I haven't had to use the VM heavily recently, however. I'm mostly using OS X at the moment. –  Benjamin Oakes Apr 9 '10 at 18:41

2 Answers 2

up vote 1 down vote accepted

If Ubuntu is your host and you have Compiz enabled, you could use the "ADD Helper" setting in the CompizConfig Settings Manager. This will "dimm" all but the active window. Note - this will apply to all windows, not just Virtualbox.

share|improve this answer

In the lower right corner of the VM window there is an icon of a downward pointing arrow. If it's lit up, then the window has focus. If it isn't, it doesn't. You can toggle it with your right Control button (or whatever you set the host key to be). This is the behavior with the Guest additions installed; not sure if this is any different without (I doubt it's different).

This doesn't apply when you're in headless mode and using RDP.

share|improve this answer
    
I can also look at the title bar, which is much larger. The issue is that I'm usually directing my attention to near the middle of the screen, not the very top or bottom corner. –  Benjamin Oakes Mar 10 '10 at 20:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.