Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can only undo once in Excel and I have taken the steps to change the number in the Edit Registry and that did not fix the problem. Help! Very Annoying!!!

share|improve this question
Did you reboot after changing the registry? Which registry key did you change? What did you change it to? – heavyd Mar 10 '10 at 17:59

I had a the same problem and the microsoft article instructions to add UndoHistory key to the registry did not help. I looked for macros that could be running - though that might be the problem, but there were none. Also checked the XLSTART folder - but no problems there. I finally found that it was an add-in that was causing the issue. It was a COM add-in from ASPEN Tech, but I would guess other add-ins may also cause the issue. If you are still having the issue I recommend disabling add-ins then checking to see if it fixes the problem.

share|improve this answer

I guess you were following this article to change the value. In most cases a registry key change requires the application to be restarted (no need to reboot the machine for application level changes), or better yet - to do the change, while the application is not running. Otherwise there's a chance that the application can overwrite your change.

So, make sure you have closed excel completely before you change the value in the registry. Open the task manager. Click on the process tab. Check if there is still excel.exe process running. If so, kill it.

Then make your change and start excel.

share|improve this answer

You must log in to answer this question.