Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having an issue with Windows 7 changing the boot order everytime I start up.

I have 4 partitions:

  • boot
  • linux
  • windows.

Grub is installed on the boot, and boots up both operating systems fine, however when I boot to Windows the bootable partition is changed to Windows and the MBR is rewritten.

How do I stop this? Its rather annoying to have to boot, chroot and fix this problem everytime.

I also don't want to use the Windows boot select.

share|improve this question

migrated from serverfault.com Mar 11 '10 at 1:07

This question came from our site for system and network administrators.

Something is restoring the Windows boot sector to the MBR. Could it be system restore, or anti-virus software?

Or could it be Adobe?

There was an article in "2006 - The Hacker Quarterly", describing a very similar issue, and this was caused by Adobe's latest software protection. If this sounds likely then have a look for the article "Hey Adobe! Leave My Boot Loader Alone!", published in the Winter 2009-2010 edition. (I'll paste a URL link here if found).

share|improve this answer
    
have a look at answers.google.com/answers/threadview/id/321444.html ... unless this is something new; i haven't found the 2600 article online to read. that doesn't sound like the same situation tho; that symptom sounds like it would look like a broken Grub, not a working Win7 bootloader. – quack quixote Mar 11 '10 at 5:05
    
Grub works .... but everytime I boot to Win7 it changes the boot loader and the partition back to windows. I can't find an option in Windows to tell it not to do this, and its a new install. – monksy Mar 11 '10 at 18:05
    
Also the only adobe product i have installed is flash – monksy Mar 15 '10 at 1:28
up vote 1 down vote accepted

I had the "makeactive" option in grub and apparently when Win7 sees that it is the active partition it latches on.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .