Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Windows 7 you can pin a document to a program in the taskbar. I pinned an .xls document to Calc, but when I click on the shortcut I get the following error:

soffice.bin - System Error

The program can't start because sal3.dll is missing from your computer.
Try reinstalling the program to fix this problem.

I got the same error when I pinned a .txt file to Writer.

I tried repairing Open Office, as suggested by the error, but that didn't fix the problem.

Any ideas? Is sal3.dll part of something that isn't installed by default?

share|improve this question
Does OO run normally when run from the Programs menu, not from a pinned file? – heavyd Mar 11 '10 at 17:59
Yes. I can launch Calc and then open the file just fine. It's only when I try using the pinned file that I run into trouble. – Ecyrb Mar 11 '10 at 22:06
OOO does not upgrade well. Try reinstalling it because sal3.dll is there on 3.2.1 – ZaB Apr 3 '12 at 18:40
up vote 2 down vote accepted

The library sal3 (Windows: sal3.dll, Unix: is located in the /program folder. It maybe necessary to add the /program folder to the PATH environment variable if the bean cannot find sal3.

There is no /program folder in Windows 7. You may find it in Program Files (x86) under "C:\Program Files (x86)\ 3\URE\bin". Add that path to the PATH system environment variable and it will work.

share|improve this answer
There is no /program folder in Windows 7, but I did search Program Files (x86) and found sal3.dll under "C:\Program Files (x86)\ 3\URE\bin". I added that path to the PATH system environment variable and it works now. Thanks! – Ecyrb Mar 12 '10 at 16:15

I had the exact same problem after updating to OO3.3. My text file shortcut was in the "Startup folder" and would not launch giving the same error (The program can't start because sal3.dll is missing...yada yada)

When I looked at the shortcut properties in the Startup folder (right click > Properties > under the "General tab") I found it had been changed from "Opens with: Notepad" to "Opens with: Open Office"!

I changed the file back to "Opens with: Notepad" - the error has disappeared and my file now opens on startup. No major registry fixes or other needed.

share|improve this answer

protected by Community May 3 '12 at 22:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.