Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I have Visual Studio 2003 running on Windows 7 - yeah I am aware it isn't officially supported - and no, unfortunately I can't change that situation :-(

For the most part it works OK but I have a specific problem, that I can't figure out. The application hangs if you do a project wide search (Ctrl - Shift - F) for a string.

I have a reasonably powerful machine and all the other heavy tasks like compiling and debugging all work fine. It also works if I restrict the search to the current document (Ctrl - F). I am running it as administrator and VS.NET 2003 SP1 has been applied.

The size of the project does not seem to be a problem since a colleague is also experiencing this issue for a single project solution containing 5 pages.

I am currently using Windows Search as a work-around and I was wondering if there is something I missed that I should try.

PS: I have asked this question on stack overflow as well - but I suspect this might be problem with Windows 7 OS - so I thought I'd cross post it here as well.

share|improve this question

migrated from serverfault.com Mar 11 '10 at 21:01

This question came from our site for professional system and network administrators.

add comment

3 Answers

have you tried not running it in windows 7? There is a special XP mode component (basically a local virtualization running XP) for exactly reasons like that ;) You can install it on windows 7, then install visual studio within that, then ru it ;)

share|improve this answer
    
Are you talking about using Windows Virtual Machine product ? Or is it the compatibility setting you get when you right-click on the shortcut to the executable ? –  Nikhil Mar 11 '10 at 8:26
    
A special version of Virtual PC - it is called Windows 7 XP mode or so. Look it up on the Microsoft Website. Specifically done for compatibility problems. –  TomTom Mar 11 '10 at 9:00
    
I can't install the virtual machine on windows 7 due to administrator policy - something about performance... So that option is not available for me :( –  Nikhil Mar 11 '10 at 9:00
    
Thanks for the suggestion though - it might be useful to someone else with the same problem :-) –  Nikhil Mar 11 '10 at 9:01
    
Then ell your adminsitrator to get lost, talk to your boss and otherwise look for a new job. You can not hae 2003 based software and at the same time tell people not to use the only proper tools to get the work done ;) I would basically give my boss my resignation and attach the administrative policy as reason. –  TomTom Mar 11 '10 at 9:36
add comment
up vote 4 down vote accepted

I got the answer on Stack Overflow where I had cross posted this question - You can get the search to work by disabling the Aero functionality. I wrote a blog post on all the tweaks I had to do on Windows 7 to get VS.NET 2003 to work.

share|improve this answer
add comment

If you want to search across a project or a solution to work then you need to tweak the compatibility settings . You can do this by right clicking the shortcut to launch VS.NET 2003 and selecting properties, choosing the “Compatibility” sub-tab and then checking “Disable Desktop Compositing” as well as “Disable Visual Themes” .(I got this tip from an answer to a question I posted on Stack Overflow).

_Abu

share|improve this answer
1  
This added no additional information. –  Ramhound Apr 6 '12 at 13:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.