Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have done something quite silly and not sure how to fix it.

I modified some of the gnome keyboard short cuts and was trying to disable the "Run Application" command. In the process I assigned it to the delete key and every time I hit delete the "Run Application" window comes up.

It would not normally be a problem but the "Keyboard Shortcuts" no long has the short cut in the window so I can't disable it.

Any help advice would be appreciated.

Cheers Ben

share|improve this question

migrated from stackoverflow.com Mar 12 '10 at 1:24

This question came from our site for professional and enthusiast programmers.

    
It probably lives in GConf, but there are scary monsters in there. Good luck hunting. library.gnome.org/devel/gconf/index.html –  msw Mar 10 '10 at 5:45
add comment

2 Answers

The entry reads "Show the panel's "Run Application" dialog box", and save royal screw-ups, there's no way to remove it. Click on the row, and as it reads on the bottom of the window, "press backspace to clear".

share|improve this answer
add comment

Normally, the way to do this is to go through the Preferences > Keyboard Shortcuts. There you can change any keyboard shortcut keys you have set, without necessarily having to go through gconf-editor.

Since you can't see the "Run Application", we have no choice but to mess with the gconf-edior.

Now, if you are willing and if you do actually wish to mess with the gconf-editor, do the following:

  1. Open a terminal window and type gconf-editor.
  2. Once you're in the application, [assuming you're familiar with the regedit in Windows] go to apps \ metacity \ global_keybindings.
  3. You will notice a bunch of values to your right. Find and select (by "select" I mean "double-click") panel_run_dialog and a window titled "Edit Key" will pop-up. In your case, you should simply type "<Alt>F2" (without the double quotes of course) in the Value textbox.

This should fix your problem.

Good luck.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.