Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Can anyone confirm if by setting the following environmental variables under Debian Lenny, it will make previous history entries not be saved? I'm using GNU bash, version 3.2.39(1)-release.

export HISTCONTROL=ignoreboth
export HISTSIZE=500

I have added them to my /etc/bash.bashrc file but I keep getting repeated commands.

share|improve this question

Use erasedups instead! It work for me!

export HISTCONTROL=erasedups

If you need more options separate them with:

export HISTCONTROL=ignorespace:erasedups
share|improve this answer

You must log in to answer this question.