Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am accessing an intranet site built by amateurs, that was constructed to be "best viewed by IE" (arghhh!). The site is in portuguese. All accented letters are jammed and do not appear as they should. As I create sites myself, I know that the best way to build a site in portuguese and other latin languages is to use the "charset=iso-8859-1" on the page's HTML encoding. This will ensure cross-browser and platforms compatibility.

But I have no way to change this, because I am a visitor on this site.

I don't know the encoding they are using. What I ask is: is there a way I can force my browser (Chrome or Firefox) to recode the page using the correct charset? I need this to work on Ubuntu.

share|improve this question
    
ISO-8859-1 is absolutely not a good encoding — i mean, it doesn’t even have dashes. –  kinokijuf Nov 7 '13 at 9:02
add comment

2 Answers 2

up vote 2 down vote accepted

In Firefox click View->Character Encoding there you can select quite a few options for the encoding.

Otherwise you could use a greasemonkey script to accomplish this. There are quite a few for various sites on userscript.

share|improve this answer
    
In Chrome, look in the Page menu, Encoding. Both Firefox and Chrome have auto detect settings in their Encoding menus that may help. (But I don't know if the auto detect settings override the character encoding specified in the HTTP response header or the HTML source, or if they only try to auto detect when there's no character encoding specified.) –  Bavi_H Mar 13 '10 at 4:18
    
thanks, I found an extension that is doing the job!!! –  Mike Mar 14 '10 at 18:44
add comment

In Chrome, click on the little file icon (near the top right), and select one of MANY encodings from the Encoding menu. (Same idea as what was mentioned for Firefox.)

share|improve this answer
1  
Clarifying: on the dropdown menu of the browser window (the only menu you got), hover Tools->Encoding and then select and encoding. –  fiatjaf Jun 14 '13 at 18:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.