Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

I used to have this problem sometimes in Vista, but now I'm using Windows 7 (it was a clean install, reformatted hard drive) I'm disappointed that it's happening again.

Basically what happens is sometimes when I right click on something and click an entry in the context menu, the highlight from entry remains on the screen, in front of everything else.

I can get rid of it by changing my theme to Aero Basic and back again, but it's not a nice solution as it takes too long and often once I get rid of it, it comes back.

enter image description here

Here you can see an example of what's happening - the highlight is there from Chrome's context menu.

Does anyone know how to fix this?

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, Dave M, Doktoro Reichard, Heptite, Kevin Panko Jul 13 at 2:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
This problem has a great work-around (still not a solution, though) here: superuser.com/questions/57016/… Use "tskill dwm" to reset the Desktop Window Manager without having to go through the other steps (like turning Aero off and then on again). I too am still looking fora REAL answer to this problem, and have yet to find a satisfactory solution :-( These workarounds are helpful, but don't actually solve the real problem. –  mHurley Jul 11 at 15:50

4 Answers 4

up vote 13 down vote accepted

I found two different answers to this when I googled

  • Update your graphics drivers

or

  • Right click on my computer, properties, advanced system settings, advanced tab, under performance - settings, and uncheck the fade out menu items after clicking

As it happens both on vista and win7 (and the problem is not uncommon, plenty of hits on google) my theory is that there is a bug somewhere in the Aero code that affects certain graphics cards

share|improve this answer
    
I don't think it would be my graphics drivers, I installed the latest about a week or two ago, so I'll try the untick fadeout. Thanks –  Charlie Somerville Mar 14 '10 at 11:46
    
Awesome, it works! –  Charlie Somerville Mar 15 '10 at 6:08
2  
Thanks for pointing out that dupe and providing a good answer +1 –  Ivo Flipse Mar 18 '10 at 10:49

Alternative quick fix: change the screen rotation and back. This can be done in a few seconds using the keyboard: press ctrl-alt-arrowdown, ctrl-alt-arrowup. The screen will flicker twice (first to flip the screen upside-down, then back) and the hover should be gone.

share|improve this answer
    
These hotkeys work only with Intel Graphics Drivers. –  DebugErr Mar 7 at 15:42

I find it that the two answers on the top didn't work and get rid of it without reseting. But after more fooling around I have found out a way to get rid of it without a reboot.

1) Right click your desktop and hit Personalize 2) Scroll down and change your theme to either Windows 7 Basic, or Classic. 3) After waiting for it to load, it should get rid of it, then you can switch back to Aero.

Then after that I would suggest doing what the top two say because it will come back on your next right click.

share|improve this answer

Here's a blog entry describing a temporary & a permanent solution. Summarized:

Temporary solution

By restarting Desktop Window Manager Session Manager, the problem is temporarily resolved. You can do this from the Services window, or by typing this into a command prompt with administrator privileges:

net stop uxsms
net start uxsms

Permanent solution

Unchecking "Fade out menu items after clicking

  1. Open the Windows' System window, and select "Advanced system settings" from the panel on the left.
  2. Under the Advanced tab, click Settings... in the Performance frame.
  3. In the list of Visual Effects, locate "Fade out menu items after clicking" and uncheck it.
share|improve this answer
    
Thank you so much for the temporary solution. I had already done the permanent one per the best answer, but there was still the 'Edit with Vim' box on-screen. –  Ross Aiken Apr 25 '13 at 16:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.