Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There is an awful stupid key on the keyboard of this Lenovo T60 I'm using which sends the browser back a page.

I really need to disable it.

I can't find it anywhere in the Keyboard settings in control panel or the special Lenovo setup utility ("Thinkpad configuration"). Thinkpad Config has everything but keyboard. Its got mouse, trackpoint..

share|improve this question
    
I am feeling the same pain. I would, however, prefer to get some use out of the keys -- page up/page down, perhaps... –  Dilum Ranatunga Mar 28 '12 at 5:01

2 Answers 2

up vote 1 down vote accepted

I found this information here at Lenovo's support forums:

Disabling the "Browser Back Key":

Get the ThinkVantage Keyboard Customizer:

http://www-307.ibm.com/pc/support/site.wss/MIGR-44185.html

Install it:

Note, after downloading/running the exe it does not install the app yet, it just extracts it. After the app gets extracted, go to the folder where you have it and run the setup. Then, reboot your laptop.

Disable the Browser Back Key:

Go to your Start menu,

ThinkVantage,

Keyboard Customizer Utility,

Key sensitivity tab,

uncheck Enable Browser Keys

share|improve this answer
    
@techie007 Except that this solution involves an extra process running in the background, rather than a one-off fix. –  sblair Mar 14 '10 at 19:45
    
Welcome to the world of notebooks with specialty keys. :) If removing all the Lenovo bloatware doesn't disable them, then they've probably assigned those keys at the BIOS level (or alike). –  Ƭᴇcʜιᴇ007 Mar 14 '10 at 19:54

My guess is that the mouse trackpad supports multi-touch, and that when typing occasionally your hand/palm accidentally "swipes" across the trackpad, activating the "back" gesture. You should be able to customise or disable this in the trackpad configuration.

Edit: A solution for turning keys "off" is described here, using SharpKeys. AutoHotKey would also work, but the SharpKeys solution changes the Windows registry, and so doesn't need to run in the background.

share|improve this answer
    
No its not that. There's this really annoying "Back" button, it has a picture of a page with an arrow going back on it. Its right next to the normal "left" arrow key. –  bobobobo Mar 14 '10 at 16:46
    
@bobobobo Ah, I assumed it was the same problem I had with a laptop recently. –  sblair Mar 14 '10 at 16:56
    
+1 for the SharpKeys suggestion. The back/forward buttons on my ThinkPads are remapped to page up/down using this tool. –  Jørn Schou-Rode Mar 14 '10 at 22:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.