Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Found an SD card (1GB) lying around. Thought I might pop that into my card reader and see if anything is on it. Nothing. There isn't even a file system on it.

I right-click and go "format" but nothing happens. So I try in command.

> format f:

Insert new disk for drive F:
and press ENTER when ready...
Error in IOCTL call.

What does this mean?

share|improve this question
Did you try formatting it on a different card reader or system? – LawrenceC May 27 '15 at 20:31
up vote 4 down vote accepted

The card is toast. Sorry. :(

share|improve this answer
but it shows up my MY COMPUTER.. thats got to mean something lol – masfenix Mar 15 '10 at 2:29

Although there is a good possibility that the card is indeed a roasted loaf of bread, try running some sort of data recovery tool on it. Data recovery wizard, ... anything like that that you can get your hands on (there are some nice free ones, but it's late and their names escape me) that have the option to recover partitions and raw data. Worth a shot; it's not like you're gonna lose anything.

Apart from that ... :-/

share|improve this answer
Provided your time is worth less than a 1GB SD card :P – micmcg Mar 17 '10 at 2:50

I'd recommend loading a Linux Live Boot CD e.g. Ubuntu and using the partition tools there for a more powerful analysis of the SD card.

If you have any luck you can format it NTFS for FAT and then it will run in Windows XP if it has life left in it.

share|improve this answer

Attempt to zero the card under Linux. Using a live CD such as Ubuntu or openSUSE, open a command prompt and type one of the following commands:

sudo cat /dev/zero > <card>
sudo dd if=/dev/zero of=<card>

Replace <card> with the actual name of the memory card device, such as /dev/sdb. Make sure that this does not refer to the system's hard drive. Then attempt to format the card under Windows or another device again.

If an error such as Input/output error occurs, the card is unusable. These kinds of cards are very cheap; a 2GB SD card costs only about $5 nowadays.

share|improve this answer

I've tried this and my USB flash drive is now working...

  1. Make the media unusable by entering the following in a Command Prompt:

    format e: /q /fs:fat32

    Where e is the USB drive letter.

    You will then get a prompt:

    Invalid media or Track 0 bad - disk unusable.

  2. Download and install the HDD Low Level Format Tool (the trial version will do)

  3. Using the HDD Low Level Format Tool, format the USB flash drive and wait until the formatting process is done.

share|improve this answer

I had a card that gave this error with a command line format on XP, and also said "the format failed to complete" in the GUI. Windows 7 just locked up trying to format it. In the end, I formatted it in my T2i CAMERA (seriously) and it worked. It seems to be fine now, and also works in my computer. Unfortunately, I can't investigate the full properties of this "solution" because I can't re-create the fault (obviously).

share|improve this answer

It's an input output controller fault. dEither a bad controller or a damaged device. Check the USB drivers , if they are fine then the SD card gone bad.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .