Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I open a CSV (comma separated values) document in OpenOffice.org Calc I get a dialog with CSV preferences.

The current default character set is "Eastern Europe (ISO-8859-2)".

I would like "UTF-8" to be selected by default instead.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

The problem was in LC_ settings in my system. It was set to:

LANG="cs_CZ"

which probably defaults to ISO-8859-2. After altering this to:

cat /etc/env.d/02locale
...
LANG="cs_CZ.UTF-8"
...

env-update && source /etc/profile
reboot # just to be sure

Everything is ok. CSV defaults to UTF-8.

share|improve this answer
    
forum.openoffice.cz/viewtopic.php?pid=4574#p4574 -> The same question in Czech (posted by me, answered by myself). Just to let Google know these questions are related. –  user14944 Mar 17 '10 at 12:16
    
Thanks for posting the answer picca. –  Richard Holloway Mar 17 '10 at 15:07

I think this is controlled by your Locale Settings.

For me CSV files default to UTF-8

In Tools > Options > Language Settings > Languages.

My Locale is set to default. My Language is set to English (UK)

The Locale of the PC is English (UK)

share|improve this answer
    
I tried this too, but no luck. Locale setting, User interface, Default languages for documents - Western. All set to English (UK). –  user14944 Mar 16 '10 at 9:07
    
I am running OOo 3.1.1 on Ubuntu Linux. I do not know if that makes a difference. Perhaps you are on an older version or you have found a bug! –  Richard Holloway Mar 16 '10 at 10:24
    
I am running OO-3.2.0 on Gentoo. It's strange that OO honors LC_ settings instead it's own settings. Anyway, I posted solution which worked for me. Thanks for your time Richard. –  user14944 Mar 17 '10 at 12:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.