Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lenovo X200 laptop on which I am running Ubuntu 9.10. Recently, (I assume after some updating, but I really don't know) my ethernet port stopped working under Linux. A more tech/linux-savvy friend of mine was able to temporarily fix the problem by manually editing the resolv.conf file with the DNS servers he found through his connection. However, after rebooting, the problem came back and now I am looking for a more permanent solution.

share|improve this question

2 Answers 2

you need to edit:

/etc/dhcp3/dhclient.conf

and prepend the dns severs to this. I think there is a commented out line for what you need.

resolv.conf is generated each time you boot.

share|improve this answer
    
I added prepend domain-name-servers 8.8.8.8, 8.8.4.4; right where the commented out line that you speak of is--with absolutely no effect. Though my computer only had /etc/dhcp/dhclient.conf, not dhcp3. –  Jay Sullivan Jun 12 '14 at 1:28
    
restart networking? –  matpol Jun 12 '14 at 7:28

actually resolv.conf is updated via ubuntu network manager upon getting a new lease from dhcp. your dhcp server ideally should give you a set of two nameservers to use in the local network. if you're behind a private broadband router it's likely that you accidentally disabled this dns feature there.

if you use the abovementioned dhclient.conf it is quite possible that your nameserver setting won't work as soon as you put your laptop in another network as not all recursive nameservers respond to all internet network ranges.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.