Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The checkbox "Use AutoPlay for all media and devices" is checked.

Yet, at some point in time, my computer has stopped giving me AutoPlay prompts.

I can't really elaborate beyond this because that's basically all there is to observe.

Does anyone know of a solution?

EDIT 19/03/2010: I have attempted to disable and renable AutoPlay a few times to no avail, in case you're going to suggest it. All options are on "Ask me every time".

EDIT 21/03/2010: HKLM\SYSTEM\CurrentControlSet\services\cdrom\AutoRun is and was set to 1

share|improve this question
1  
I have noticed the exact same problem, with 2 different installs of Win7. It works fine for a period of time after initial installation of Windows then at some point it just stops. –  Shevek Mar 26 '10 at 12:45
add comment

2 Answers

up vote 8 down vote accepted
+100

The Windows AutoPlay system is quite complex and its behavior depends on a lot of registry settings.

enter image description here

Unfortunately, the AutoPlay Control Panel applet in Windows 7 doesn’t allow you to change system-wide settings. So it’s possible that ”Use AutoPlay for all media and devices” is checked, but AutoPlay is still disabled.

To enable AutoPlay use either of the following methods:

Using Group Policy Editor

Open Local Group Policy Editor (gpedit.msc), navigate to Computer Configuration / Administrative Templates / Windows Components / AutoPlay Policies and change the Turn off AutoPlay policy to Disabled.

After that you can reset it to Not Configured, which is the default state.

Using Regedit
Unfortunately Group Policy Editor isn’t available on Windows Home editions, as an alternative you can use regedit.

Open regedit and locate the following key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

change (or if it doesn't exist create a new DWORD) NoDriveTypeAutorun to 0x91

For more information please read the following KB article: How to disable the Autorun functionality in Windows

share|improve this answer
    
I'll give this a go tonight when I get home... –  Shevek Mar 26 '10 at 12:46
    
This worked for me, although it was already set to Not Configured - I set it to Enabled, then Disabled, then back to Not Configured (clicking apply after each one) and I now have my AutoPlay working again! Many thanks... –  Shevek Mar 26 '10 at 19:52
    
I unfortunately can't access gpedit.msc; I'm on Windows 7 Home Premium. –  unrelativity Mar 26 '10 at 22:49
    
I tried following the link mentioning HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\ CurrentVersion\policies\Explorer\NoDriveTypeAutorun, but my regedit shows that policies doesn't contain anything beyond (Default). Perhaps I could create a sub-key, but the link only shows the value for disabling, not enabling. –  unrelativity Mar 26 '10 at 22:52
    
Check the key under HKEY_LOCAL_MACHINE, not HKEY_CURRENT_USER. Machine settings override per-user settings. The deafult value for NoDriveTypeAutorun is 0x91 for Vista & Windows 7. –  Ryck Mar 27 '10 at 8:02
show 3 more comments

Besides Use AutoPlay for all media and devices make sure you have the Ask me every time option set for all items under Media and Devices

alt text

share|improve this answer
    
Everything is on "Ask me every time" already. –  unrelativity Mar 19 '10 at 8:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.