Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am dual-booting Ubuntu 9.04 and Windows XP but am new to Ubuntu. In Windows, I use an M-Audio Audiophile 2496 sound card for recording (because it has RCA input jacks for my mixer), but I don't use it for playback (because my speakers use a 1/8 inch jack); instead, I use the motherboard's built-in sound card.

I tried to recreate this arrangement in Ubuntu, but despite selecting the built-in card for all playback under System > Preferences > Sound, I still have inconsistent results. Rhythmbox plays back through the integrated card, but Flash content in the browser and games in the OS send their audio to the Audiophile card.

I have seen recommendations to use a program called "Jack" to control this, but I installed it and found it baffling.

How can I control which card is used for playback, other than disabling one card (as I discovered how to do and explain below)? Also, is there a GUI for disabling hardware, or is it necessary to edit a configuration file?

share|improve this question

migrated from serverfault.com Mar 16 '10 at 11:14

This question came from our site for system and network administrators.

1 Answer 1

Since I don't really need the PCI sound card to work when I'm booting Ubuntu, I eliminated the confusion by disabling it. Here's how:

1) I opened Terminal and typed less /proc/asound/modules to get a list of the audio drivers being used
2) There were two listed: snd_hda_intel, which I recognized as the built-in sound card, and snd_ice1712, which I guessed was the Audiophile 2496
3) From terminal, I typed sudo gedit /etc/modprobe.d/blacklist.conf to edit the list of drivers that are "blacklisted," meaning they are not loaded at startup. I added these lines to the bottom of the file:

#Disable M-Audio Audiophile 2496
blacklist snd_ice1712

4) I rebooted. Now the Audiophile card was disabled and all sound came through the built-in card. Success!

Note: I found this solution mainly here, so thanks to natewiebe13.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.