Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows XP computer with Chrome set as the default browser. However whenever I click a link embedded in a pdf document I'm viewing with Adobe Reader 8.2.1 I get a popup security warning asking if this is ok, and then the Reader opens the link in IE.

Is there a way to change Adobe Readers default browser?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

The fact that URL links from within Adobe Reader always launch Internet Explorer instead of the default browser, say Firefox, seems be a common problem from within the Reader, and from within the Help (Google "Adobe Reader default browser").

Last year Adobe's own tech note declared it "a rare problem and there is no known solution": http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_15579 and the problems continue in relation to Vista [HTML links don't open in default web browser on Windows Vista (Adobe AIR)]: http://kb.adobe.com/selfservice/viewContent.do?externalId=kb403122

It also seems to have been a problem for long time going back to early versions of Mozilla Firefox 1.06. Various other forums too suggest that it's just a matter of using Start | Set Program Access and Defaults, and choosing "Use default browser" or forcing Firefox to be the default. http://www.velocityreviews.com/forums/t219716-adobe-reader-6.html Like contributors here, I found that neither method worked.

Note that Mozilla's own useful KB article: http://kb.mozillazine.org/Default_browser#Force_Firefox_to_make_itself_the_default suggests you set individual file types to default to FireFox, but I had already had those set anyway.

The solution I chose to make URL links in PDFs trigger my Firefox browser reliably was to dump Adobe Reader and install the faster and smaller Foxit Reader (http://www.foxitsoftware.com/pdf/rd_intro.php). The only change you have to make inside Foxit is to tick the "Create links from URLs" tickbox under Edit | Preferences | General.

Source: http://www.acrobatusers.com/forums/aucbb/viewtopic.php?id=7931

share|improve this answer
2  
TL;DR No, use Foxit Reader instead. –  Sindri Traustason Mar 16 '10 at 13:34
add comment

Acrobat User Community Forums exactly cover that issue. Sergiy Byelozyorov's answer is, in fact, the exact copy of the answer of paulc in the relevant thread. I recommend you to read the full thread for the whole story.

However, since the thread is old (the latest message was on June 2008), it may be worthwhile to check Adobe Reader's Edit > Preferences > Internet > Internet Settings > Programs > Default web browser menu to see if it is possible to change default browser on version 8.2.1. If you can't, then Foxit Reader is a good substitute for Adobe Reader.

share|improve this answer
    
Yes, indeed I copied an answer from there. Sorry, I forgot to add source to my answer this time. I typically do that whenever I am citing some other web-site. –  Sergiy Byelozyorov Mar 17 '10 at 14:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.