Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows Vista business edition on my Lenovo R500. Every time I connect a second external monitor my default laptop desktop shifts to the second external monitor automatically.

How can I stop this behavior? I don't want the laptop desktop shifting to the second monitor.

share|improve this question
1  
For me this happends only while operating still is not yet loaded. Once I get Windows loaded, screen moves back to laptop. –  Sergiy Byelozyorov Mar 16 '10 at 13:03
add comment

5 Answers

Try the external screen button (probably F7).

enter image description here

That may get you the configuration you want.

If you plug in the screen, switch the laptop to primary, then disconnect and reconnect the screen, does it still become primary?

share|improve this answer
add comment

If you have the Lenovo tools installed on your laptop, bring up the monitor configuration tool with Fn and the appropriate Function key. On my W500 it's F7, but I don't know if it is necessarily the same on your R500.

Note - this isn't the Windows Display control panel, it's a specific Lenovo tool.

enter image description here

Click on "Manage Schemes" in the bottom lefthand corner to change the available monitor configurations.

enter image description here

Chances are that your default "Docked" profile is set to use the external screen as the primary one.

share|improve this answer
    
This will work after the PC loads Windows, and only if he has the hotkey and the driver installed. The key combination is FN+F7 on all Thinkpads. To fix it correctly it needs go to BIOS as stated in the answer below. –  Melvyn Mar 29 '10 at 18:16
add comment

You must set in the BIOS. Look around and find the option for graphics. It will give you some options to choose:

Power on, hit F2 to get BIOS

Config -> Display -> Boot display device:

  • ThinkPad LCD
  • Analog (VGA) <-- You have this set
  • VGA+LCD
  • Digital (DVI)
  • DVI+LCD
  • VGA+DVI

Set default to ThinkPad LCD. I'll reboot my ThinkPad and check the right order later.

You can choose LCD+VGA and have exactly mirror windows.

If you have a dock station take the first option (Primary display) to Internal (laptop) instead of PCI Express (dock station).

Enjoy

share|improve this answer
add comment

Use the graphics driver software's latest versions (its easy if your video h/w is nVidia or ATI) and set the primary and secondary displays from inside there. This usually fixes it. Better if you can install addon software with nice special apps and functions that latop manufacturers usually make available for download from their support site.

This works better than others because they know the quirks of the actual bios and h/w they use :) Only make sure its compatible with the ltest update of the OS - windows update only 50% of the time updates the drivers to the latest. Best way is to go and download from the laptop manufacturer's website.

share|improve this answer
add comment

When you've got the external monitor plugged in which is the primary monitor?

If it's the external monitor then that might explain the problem. Set the laptop's screen to be the primary and see if that cures the problem.

share|improve this answer
    
When i plug the second monitor, the laptop is usually the default. –  user31333 Mar 16 '10 at 12:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.