Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Gigabyte P55-UD3 motherboard which comes with a Realtek sound card and audio header for the front panel. My headset is permanently connected to the front panel (mic in, headphones in) and I also have speakers connected at the rear of the computer. What I want to achieve is that both the headphones and the speakers work at the same time.

On my old PC with Realtek, I was able to do this by clicking "Device advanced settings" in the Realtek HD Audio Manager and then clicking "Make front and rear output devices playback two different audio streams simultaneously" and then doing some reassigning of front/rear settings in the Realtek Audio Manager (can't remember the details).

But that doesn't seem to be working now - either the speakers play sounds or the headphones, not both at the same time.

To pose the question differently, Windows plays the sounds on the "default device". I'd like to make both headphones and the speakers kind of like the default devices.

share|improve this question
add comment

7 Answers

up vote 8 down vote accepted

You need to disable "Front panel jack detection". This will make the front and rear jacks play the same stream.

Source: http://www.tomshardware.com/forum/243915-49-realtek-audio-manager-sound-signal-simultaneously-front-rear

Screenshot

share|improve this answer
    
Holy crap this has been bugging the crap out of me today. Thanks! –  rossipedia Jan 29 '13 at 21:06
    
How can I get the Realtek Audio Manager? I downloaded the latest driver from Realtek website but it didn't come with it. –  LWZ Jun 10 '13 at 4:19
add comment

You could always buy a headphone splitter for a few $$ or ££ or €€

headphone splitter

share|improve this answer
add comment

I solved the problem with different output to the front panel on my ASUS P5P43TD.

All you need to do is to go to Onboard Devices Configuration in BIOS settings and change Front Panel Type from HD Audio to AC97

After restarting you have now Tab called HD Audio 2nd output in Realtek Audio Manager (but keep Speakers tab as default output).

If you can't see that Tab, go to Device Advanced Settings and change it to Make Front and Rear output devices playback two different audio streams simultaneously. If you choose the other option in Advanced, you will have only one stream but from both outputs - front and rear.

And now you have multiple choice for output in popular applications such as audoi- and video-players, where you can change output to Speakers or to HD Audio 2nd output.

As a result my Foobar2000 (audio) and MPC (video) are playing onto different outputs as I'm typing this post.

For some games you can choose the output too (Black Ops) in game Sound options but in some of them you cannot (MW II) BTW if you don't set anything as Default in Realtek Audio Manager you won't have any sound in MW II and some other games.

share|improve this answer
add comment

It depends on your hardware. Your old machine sounds like it had a card that was capable of multiple output streams. Check out the specs on your Gigabyte board and see if the sound card is capable of this.

Also, do you have the same 'Realtek HD Audio Manager' as you did on your old PC? If you do, check to see if this option is there. If it is not, it's probably hardware incompatibility.

share|improve this answer
    
The new Audio Manager looks practically the same as the old one and the option is still there - it just doesn't work the same any more. But maybe I'm missing some important configuration setting? –  Borek Mar 16 '10 at 15:30
add comment

Got this working finally. If you are able to get the above screen with both "Speakers" and the "HD Audio 2nd output" tabs. (ie front panel headphone jack) then do as described above - click the yellow folder in Realtek HD audio Manager and check disable front panel jack detection). For whatever reason, this changes the "HD Audio 2nd output" to "Mic in at front panel (pink)" which was not visible before. Set speakers as default and click "Device advanced settings" and mute the rear output device when headphones are plugged in. Not sure why you would have to select this, but this was the only way to get mine working.

Couldn't there just be a check boxes for all devices and what sounds to play through them? Seems this would be easy to implement.

ADDED: Tested the previous answer - selecting speakers for the front panel device type does work without having to disable front panel jack detection but you still have to keep "Mute the rear audio device when headphones are plugged in" checked. It basically combines the front panel and rear jacks into a single output and you lose independent control of front panel audio.

share|improve this answer
add comment

You want the SAME sound out of the front "headphone" (green jack) and speakers, both together, And NOT to mute speakers when you plug in the headphones?

In that case in the Audio Manager (should open when you plug headphones in), click the front green jack icon, and tell it you plugged in front speakers, NOT headphones - now you should have the same sound from your main speakers AND your headphones.

share|improve this answer
add comment

I had a heck of a time getting both to output simultaneously. The previous answers may not work for setups like mine since I'm using analog headphones and digital USB speakers. Here's a quick rundown of my settings (pretty sure these are what count).

Realtek HD Audio Manager:

  • Disable front panel jack detection
  • Make front and rear output devices playback two different audio streams simultaneously

Playback Devices:

  • Headphones set as Default Device and Default Communications Device

Recording Devices:

  • Realtek Digital Input checked Listen to this device, playback through Headphones
  • Stereo Mix set as Default Device and Default Communications Device, checked Listen to this device, playback through Speakers

Once I got it working it still worked immediately after disabling Realtek Digital Input, but I swear I could not get it to work before it was enabled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.