Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed a fresh XAMPP on OSX. Apache runs and I can see the splash page.

I open the httpd.conf and I set both places that point to htdocs to someplace else, which results in Apache showing an "Access Forbidden!" message.

I plugged my directory here:

<Directory "/Applications/XAMPP/xamppfiles/htdocs">

and here:

DocumentRoot "/Applications/XAMPP/xamppfiles/htdocs"

I have set the permissions to 777 for everything including the enclosing directory, but to no avail. I've also set the owner to nobody, just like htdocs.

Strangely, I just did this whole thing with MAMP and had no problems serving that directory, but it was slow.

share|improve this question
    
Thank you, this is a good point and works well. I found out that permissions of 701 are sufficient, i.e. the directories need to have "execute" permission. Read permissions are not required. Execute permissions on folders are required to open them (as can be see here also: support.apple.com/kb/HT2963?viewlocale=en_US: "Also note that you must have execute permission for any folder that you can open; thus File Sharing requires execute permission set for other, world, and everyone for the ~/Public folder, while Web Sharing requires the same setting for the ~/Sites folder."). –  user53230 Oct 22 '10 at 17:46

2 Answers 2

up vote 1 down vote accepted

It is not enough to set the permissions to 777 for the DocumentRoot and its enclosing directory. Permissions must be 777 (or something lesser, but I don't know what) for all directories from / down to the DocumentRoot. That's why this guy learned to put his vhost directories in his user directories: while it's more flexible than that, the point is the same.

share|improve this answer

This solutions works for me

<Directory />
    Options All
    AllowOverride All
    Order deny,allow
    Allow from all
</Directory>

Ref: http://serverfault.com/questions/124821/access-forbidden-using-xampp-on-macosx-10-5

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.