Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am currently running Windows 7 Ultimate 64-bit with a dual monitor setup with an NVIDIA 7950 GT graphics card. One monitor is dedicated to this machine and the other monitor is connected to a DVI KVM switch.

When I switch to my other computer, Windows 7 disables the monitor. However, when I switch back it does not re-enable the monitor. The only circumstance that automatically re-enables the second monitor is when I switch back after Windows has put the monitors into power save mode. I am continually having to bring up the NVIDIA control panel to have it re-enable the monitor.

Under Windows XP I would just disable the NVIDIA service to prevent it from auto-detecting the monitor (which doesn't solve the problem under Win7), and in Vista there was a registry hack that would prevent this. It looks as though that has been removed in Windows 7.

I have found similar questions posted on this site, but nothing that matches my problem exactly. The following link is the question that comes the closest, but does not provide a solution to the problem.

http://superuser.com/questions/96683/how-to-fix-monitor-detection-on-windows-7

Is there a way in Windows 7 to disable monitor auto-detection?

Update: I just added a second graphics card to my Windows 7 64-bit machine. I plugged one monitor into each graphics card. Now, when I use the KVM switch to switch back and forth it will re-enable the second monitor like it should. There are however, a few quirks with this. If I have a program maximized on the second monitor and it has focus, when I switch it will move to monitor 1. If I have a program maximized on the second monitor and it does not have focus, when I switch it will behave like it is minimized and when I bring it back up it will show up maximized on monitor 1.

Definitely better than it was, but still looking for a way to disable the auto-detection.

share|improve this question
    
I closed, but reopened it, after noticing that the previous question didn't answer yours –  Ivo Flipse Oct 18 '10 at 16:56

7 Answers 7

Maybe this is too simple, but have you tried just using the windows+p hot key? That works only in windows 7, but is a quick way to extend, duplicate, or select a single screen. (note: when it says projector is means your secondary display)

If you're dealing with Windows Vista you can turn off Auto-Detect through following this guide. It is supposedly only for nvidia cards but may work for others as well.

That post says:

  1. Open the Start Menu. A) Click All Programs -> Accessories -> System Tools -> Task Schedular.

OR

  1. Open the Control Panel (Classic View). A) Click Administrative Tools -> Computer Management.
  2. Click Continue for the UAC prompt.
  3. In the left pane, expand Task Scheduler, Task Scheduler Library, Microsoft, Windows, and click on MobilePC.
  4. In the middle pane, right click on TMM.
  5. To Disable TMM - Click on Disable.
  6. To Enable TMM - Click on Enable. NOTE: TMM is enabled by default in Vista.
  7. Close Task Scheduler.
  8. Logoff and logon, or restart the computer to see the change.

You can also do it directly from the registry:

Using Windows Registry Editor Open Windows registry editor(regedit) Navigate to this location

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TMM

Right click on the (UseIViewHelper) value and select modify. set the value data to 0 to disable TMM feature in Windows. If you want to re-enable TMM feature,set the value data to 1.

You also have to restart the PC afterwards.

reference

As far as windows 7 goes, it's not possible at the moment. According to moderators at microsoft's forums: "This behavior is by design and I don't think there is a way to override this functionality except to make sure that both monitors are turned on when you start the system." Pretty lame. Right now however there is a way to request this feature. Please go to the link and request this feature if you feel it is important. Also a ticket for the feature has been created officially as well. Only time will be able to tell.

A Third party software may be useful, but I have not personally used any for this purpose. I have found MultiMon which is built for multiple monitors. Hopefully this will be of some use until microsoft gets it right.

share|improve this answer
1  
The additional information you found applies to Windows Vista only, see Note within fourth paragraph Transient Multimon Manager (TMM) - the TMM task is absent in the Windows 7 Task Scheduler Library accordingly. –  Steffen Opel Aug 27 '10 at 12:10
    
I'm still curious if the Windows+p hotkey worked out. –  KronoS Aug 27 '10 at 16:08
    
<< this comment was originally posted as an answer but has been relocated along with it's replies --DMA57361 >> @KronoS: No, using Win+P does not solve the problem. Sure, it lets me reenable the second display, but it still forces every window on my system onto the small display when I switch to the other machine with the KVM. –  Billy ONeal Feb 10 '11 at 19:40
    
Being punished for being generous to resolve an important issue is a pity indeed, so have some chip in votes ;) Do you actually receive an upfront warning for this loss of abilities? Stack Exchange engine wise there is clearly room for improvement regarding these dependencies, though admittedly there are quite some 'messy real world' issues (i.e. edge cases) involved. –  Steffen Opel Feb 10 '11 at 19:40
    
@ Billy ONeal... How about disabling TMM through registry. Has that helped? –  KronoS Feb 10 '11 at 19:40

In case of NVidia card you need to disable "NVIDIA Update Service Deamon" services.

  1. Run "services.msc"
  2. Disable those services
    • Change execution to manual
share|improve this answer

To disable monitor detection, with AMD/ATI gfx cards under Windows 7, search for DMMEnableDDCPolling registry key and set it to 0 (it is DWord). There are several places in the registry where this key is located. Change them all and reboot. Doing this will disable constant polling of the display driver to detect if user attached a monitor.

If you lack the entry, look for UMD keys under HKLM\SYSTEM\CurrentControlSet\Control\Class{4D36E968-E325-11CE-BFC1-08002BE10318}\ and add it to those.

share|improve this answer
    
I have a brand new ATI card with the Catalyst 10.5 driver on it on Windows 64-bit; I don't have any registry keys with this name. Do you know if it might be under another name? I searched a few pieces of "DMMEnableDDCPolling" and didn't have any luck hunting. Thanks a lot for the suggestion. –  James McNellis May 29 '10 at 3:35
1  
He's looking for a NVIDIA Fix and not ATI. –  KronoS Aug 27 '10 at 16:05
    
Yes, this is a fix only applicable to ATI / AMD devices, but it is a valuable contribution all the same. It worked for me. –  David Sep 11 at 14:52

There is a piece of hardware can probably solve your problem.

The purpose of such a device is to sit in between the cable of your monitor and to make the computer think the monitor still exists. It does this by recording the EDID once and repeating it all the time afterwards.

share|improve this answer
    
Welcome to superuser. Without explaining how these tools help you solve your problem, and what they actually are (in case the links change) your answer is rather incomplete. You may want to elaborate on what these devices are and how they help disable monitor auto-detection. –  Journeyman Geek Nov 1 '13 at 2:24
    
Thank you, I improved my answer –  Jeroen Vermeulen BVBA Nov 1 '13 at 2:41

I have a similar situation to you, except instead of a kvm I have my main system plugged in with DVI and the secondary on VGA. That way I use the monitor's input select.

If that's not good enough: What KVM are you using? Do you have the same problem if you unplug and plugin the cables? Does turning the monitor on and off get Windows to detect it?

Maybe you need a better kvm? (That makes both computers think they're connected to a monitor.)

share|improve this answer
2  
I'm currently using a gefen 2x1 DVI KVM. Unfortunately, when I switch it disables the monitor in Windows 7. It does not do this under XP. Changing the KVM is not an option. I can get the monitor to come back if I open the NVIDIA control panel. That causes windows to auto detect the monitors again. It is weird though, that if I have switched away long enough for Windows to put the monitors in "sleep" mode, when I switch back it will correctly auto detect the monitor. –  Jay Yother Mar 26 '10 at 3:04

The only thing I can come up with, which isn't a very good solution is to buy a better KVM.

My first old KVM had the exact same problem as you are saying. I upgraded to a brand new digital one and it basically emulates/fakes a signal, even when you are not on the channel.

Other than that, I have created a registry fix for you that should disable TMM in Windows 7.

share|improve this answer
    
Diabling TMM doesn't seem to work either. Any other settings in the registry that might do the trick of stopping Auto-Detection? –  KronoS Sep 1 '10 at 22:46

Have a look at your services. I had a similar problem and disabled "AMD External Events Utility" and it stopped looking for the monitor. I think on my old system it was called "ati hotkey poller"

share|improve this answer

protected by studiohack Apr 27 '11 at 1:39

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.