Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two NAS (Buffalo Linkstation Pro, WD MyBook World), which are connected to 2 PCs with a Gigabit LAN connection. All devices are in "Gigabit mode", meaning all show that their connection speed is really 1 GBit. But the transfer rates to and from the NAS drives are very low, on average 5 MByte/sec, copying large files with several GByte in size.

Looking at the spec of the Buffalo drive, it should do up to 30 MBytes/sec. Of course, this is probably a best case scenario, but I think more than what I have right now should be possible.

Copying files between the two PCs is much faster, about 25 MBytes/sec.

What could limit the data transfer? What can I do to increase it?

share|improve this question

4 Answers 4

up vote 5 down vote accepted

The WD MyBook World is CPU-bound or disk-controller-bound. If you do an online search for the throughput of the first versions of MBW, you will find that 5MB/s is quite common. There is nothing you can do about this.

share|improve this answer
2  
    
+1 was about to say that it is cpu-bound. –  sybreon Aug 21 '09 at 16:42
    
Wow, that's an eye opener. So basically, WD is selling junk but putting a GBit sticker on it so people won't realize how bad it is until after the purchase. That doesn't produce returning customers... –  Holgerwa Aug 22 '09 at 13:50

Do your NASs support Jumbo Frames? And does your router/switch support Jumbo Frames? Check if they do, and if so, switch them on.

share|improve this answer
    
I had Jumbo Frames enabled before, but checked again to make sure: PCs, NAS and switches support Jumbo Frames, on PCs and NAS that's enabled. I guess the switches just support it since there is no setup. –  Holgerwa Jul 24 '09 at 15:17

I wouldn't worry too much about Jumbo Frames if the maximum possible speed is in the order of 30MB/s.

First thing to check is that the NAS is not doing anything else (other transfers, other actions) at the same time, because home NASes typically have severely limited processor capacity.

It also depends heavily of the source and target of the transfer... the slowest link in the chain sets the top speed... so if you move files between the two NASes, then the overall speed will be that of whichever is the slowest NAS.

Most modern harddisks should be able to do 50-60MB/s easily, but... if you put an older 'spare' harddisk in one of your devices this could very well also be limiting the maximum speed.

I would not imagine that the computer that is doing the transfer is likely to be the bottleneck, but if you bring up the process manager you can have a look at the CPU and network graphs and see if either of those is peaking at the time... it could easily be that the network port on your PC is maxed out with other traffic meaning that there is only 5MB/s left.

Based on the 5MB/s I'd almost have assumed that maybe the port on the PC (the middleman) is a 100Mbit port, because that'd make sense... 100Mbit = approx 10MB/s, but since the PC might be copying from one NAS to another, that means half the bandwidth is available for each connection.

share|improve this answer
    
I copy a large file (10GB) from a PC's local disk to one NAS. Transfer: 4,5MB/sec; CPU utilization: 15%; Netzwork traffic: 4%. Only NAS, PC and switches are on, second PC and second NAS are off to make sure they are not doing anything on the network. But that's the issue: Why is not more of the available resources used? –  Holgerwa Jul 24 '09 at 15:20
    
What kind of harddisk(s) are in the NAS you are copying to? ... and what is the model no. of the NAS? –  jerryjvl Jul 24 '09 at 21:25
    
The Buffalo NAS has a Samsung HD103UJ, 1TB, 7200rpm. Sounds not too bad, it should not be the bottleneck. –  Holgerwa Jul 27 '09 at 20:05

Check your port duplex settings. Routers/Switches set to Auto often set the ports to Half duplex. Check the port settings on the PC, Router, and NAS to see fi they are all 1GB Full duplex.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.