Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Notes: OS is windows 7, browser is latest firefox.

After saving a zip file to the desktop, Windows Media Center opens up. I looked around its config settings but could not find anything related to zip files. How do I turn that off?

Also, don't know if this should be a separate question or not:

Unless I right click > save link as... for zip files, I don't get a firefox dialogue asking what to do with the file (Open/Save). The files get saved to some place like c:\users\namegoeshere\appdata This only happens on the win7 computer. I looked around in firefox's settings for saving files, and I do have 'ask me where to download...' enabled.

I can get more exact path names when I get home.

share|improve this question
add comment

2 Answers

It sounds like you need to re-associate Zip files with the right program.

Find a .ZIP file, and right-click it. Pick "Open With..." and then pick Windows Explorer (or whatever unzip program you have installed and would like to use). Ensure "Always use the selected program to open this kind of file" is check-marked, and hit OK.

The FireFox problem should probably be a separate question, as it's probably a different solution. :) But for that I'd suggest trying FireFox without any add-ons loaded, as you may have a file saving helper plug-in (or alike) that's preventing the Save As dialog.

HTH

share|improve this answer
    
Thanks very much, associating zip files with 7zip & changing behavior in firefox's options>application>compressed to 'always ask' fixed it. :) –  gpryatel Mar 18 '10 at 5:55
add comment

Click the Start button and then click 'Default Programs' (this you will find on the right of the menu under the Control Panel option.) When the default programs window opens, Click the 'associate a file type or protocol with a program' option. The Set Associations window will now open, but may be slow to populate. Once it has populated scroll down to the zipped file extension ie .zip file and make sure that it is associated with window madia player (depending upon which you have installed on your system). If it says that it is associated with Media Player, then Click the 'change program' button and see if zip file opener (wnrar) is available in the list. If it is then select it and then click the OK button. If it isn't available then click the browse button, locate the icon and then associate the file with the program.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.