Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My win7-64 ultimate has set the clock ahead 2 hours. It appears to have done it in increments of 1 hour, with the second 1 hour shift made sometime today. The first, correct, shift for Daylight Savings was sunday morning. In the clock settings it says Mountain Time UTC-7, but the official time should be Mountain Time UTC-6.

Update for Windows 7 (KB979306) IS installed.

Microsoft appears to be able to turn even setting the clock into a hairball. I need the clock rock solid since I use the computer to record TV programs.

share|improve this question
Do you sync to an external time source? And have you verified that your time-zone is set correctly? – MDMarra Mar 18 '10 at 2:24
-- time zone is correct. Was syncing to, just changed it to, perhaps this will help. I am not the only one with this problem. – P a u l Mar 18 '10 at 2:52
-- not only this 2 hour problem, the time was off by about 3 min, so much for syncing. This has always worked for me on earlier systems. – P a u l Mar 18 '10 at 2:53
-- shifting the time 2 hours has nothing to do with my time zone anyway. – P a u l Mar 18 '10 at 3:06
Set your time server to -- is horribly overloaded (so is Microsoft). – Alexander Burke Mar 18 '10 at 4:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.