Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This morning firefox told me it needed to upgrade an addon (noflash) and I told it to go ahead. Now Firefox won't start.

  1. How can I prevent Firefox from loading the addons?
  2. Where are the Firefox config files?
  3. How to I start Firefox.app from the terminal, so I can pass a parameter?

UPDATE I was able to start Firefox in safe mode by holding down the 'alt' key while clicking on the dock icon. (see my answer below)

so problem 1 (the main problem) is solved .. can anyone help me on 2 and 3?

share|improve this question
    
I have updated my answer for your 3rd question –  Mark Mar 18 '10 at 12:01

4 Answers 4

up vote 1 down vote accepted

Hold down the option key, as you start Firefox.

share|improve this answer
    
thanks, that solves the problem of safe-mode! –  lexu Mar 18 '10 at 8:39

On a Mac, you should have "locate" installed (I did on my mac, which I had a few years ago ...) so if you can open a terminal (usually in Applications/Utilities/terminal) you can just say "locate firefox.app" (or even "locate firefox") and it'll find it. Barring that, you can also do:

sudo find / -name "firefox.app"

"find" definitely exists on OSX.

share|improve this answer
    
I'll look for 'locate' or I could write a shell script using sudo find / -iname "firefox.app" thanks for the tip (+1 for that)! BUT Alas, I already found 'Firefox.app', I need a way to run it from the command line –  lexu Mar 21 '10 at 12:27

If by config files you mean your profile it is located in your user home directory under the following path (xxxxxxxx is a random string)

~/Library/Application Support/Firefox/Profiles/xxxxxxxx.default/. 

To start firefox from the terminal do the following (see here for a reference)

/Applications/Firefox.app/Contents/MacOS/firefox
share|improve this answer

I clicked the firefox icon in the dock while holding down the 'alt' button. Firefox came up in safe mode and presented me with a dialog where I could disable all addons ..

I now have all addons except noflash (uninstalled) working again and am editing this text using Firefox.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.