Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Windows x64 and I'm not able to make msysgit to work using pagent authentication.

Here are some details:

The problem is that:

 plink -v -a -ssh git version
 FATAL ERROR: Network error: Connection timed out
share|improve this question
up vote 3 down vote accepted

As silly at it may seam the reason for this problem is that plink will use the default hostname/ip from the Default Settings and will ignore command line parameters.

The solution is to remove hostname/ip from Default settings.

Also if you fail to connect due to fingerprint you should first connect one time using putty in order to store the fingerprint, just run putty

share|improve this answer
I don't have a ip or hostname set in PuTTY default settings but I still have this issue. from win7, plink can't connect to my server boopsie by hostname - it's appending .home and going to a totally different ip: > c:\me>plink -v me@boopsie > Looking up host "boopsie.home" > Connecting to port 22 But command line works fine: c:\me>ping boopsie Pinging boopsie[] with 32 bytes of data: Reply from bytes=32 time<1ms TTL=64 – lonstar Mar 11 '13 at 23:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .