Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Somehow in trying to cleanup my computer's hard drive, I have inadvertently corrupted WordPad, which I have long used for viewing many types of files, including logs (i.e., log4j).

Now, when I right click one of these files and choose "Open with" and "WordPad", I get an error:

fn is not a valid Win32 application).

I've researched this issue, tried reinstalling wordpad.exe, but I still get the same error.

share|improve this question

migrated from stackoverflow.com Mar 18 '10 at 14:06

This question came from our site for professional and enthusiast programmers.

1  
This isn't programming related, should be moved to SuperUser –  Ben Everard Mar 18 '10 at 14:05
    
is "fn is not a valid Win32 application" the actual error text? sounds like you've corrupted the file association or other registry keys, not the actual WordPad application. not sure how you'd fix it though. –  quack quixote Mar 18 '10 at 16:10
    
Substituted "fn" for the actual file name, but otherwise the message is accurate. Suspect you are correct about corrupting something other than the application, which still works. It's the right click and open with that doesn't work now. Don't have any idea how to fix whatever is causing this problem. Notepad is okay, but I prefer Wordpad because it doesn't "wrap" lines. –  user31546 Mar 19 '10 at 15:15
    
@user31546 you can disable word wrap in Notepad, just uncheck "Word Wrap" under the Format tab. –  Breakthrough Apr 27 '12 at 20:51
add comment

1 Answer

I would suggest you an alternative like Notepad++

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.