Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am on an old laptop with Ubuntu 9.10 installed. I once tried to not shutdown but got into one of the resume states. On the next power on, resume did not work, but there was an error message during boot asking me for the resume image (which I do not have or know of) and when I press enter the normal boot happens.

This error now pops up on every boot. How can I restore the previous behaviour? Why does the boot process guess there would be a resume image and how can I delete this information?

I would like to post here the error messages from the boot process, but they are not in /var/log/syslog, where else might they be?

Here's a screenshot of the boot screen where it hangs:

screnshot

Edit:

$ sudo ls -la /dev/mapper
drwxr-xr-x  2 root root      80 2010-03-18 19:37 .
drwxr-xr-x 15 root root    3400 2010-03-18 19:45 ..
crw-rw----  1 root root  10, 60 2010-03-18 19:35 control
brw-rw----  1 root disk 252,  0 2010-03-18 19:37 cryptswap1

Edit 2:

This is the tail of my /boot/grub/menu.lst:

## ## End Default Options ##

title           Ubuntu 9.10, kernel 2.6.31-14-generic noresume
uuid            70fcd2b0-0ee0-4fe6-9acb-322ef74c1cdf
kernel          /vmlinuz-2.6.31-14-generic root=UUID=9b454298-18e1-43f7-a5bc-f56e7ed5f9c6 ro quiet splash apm=on$
initrd          /initrd.img-2.6.31-14-generic

title           Ubuntu 9.10, kernel 2.6.31-14-generic (recovery mode)
uuid            70fcd2b0-0ee0-4fe6-9acb-322ef74c1cdf
kernel          /vmlinuz-2.6.31-14-generic root=UUID=9b454298-18e1-43f7-a5bc-f56e7ed5f9c6 ro  single
initrd          /initrd.img-2.6.31-14-generic

title           Ubuntu 9.10, memtest86+
uuid            70fcd2b0-0ee0-4fe6-9acb-322ef74c1cdf
kernel          /memtest86+.bin

### END DEBIAN AUTOMAGIC KERNELS LIST

I already added noresume. But this not what I see as the boot screen. And the first entry of my boot screen has no "noresume" and still does try the resume (which does not work). Why does grub not use this list?

Edit 3: When I edit the boot entry manually during boot (with "e") and append "noresume" this works fine. But only once.

share|improve this question
    
if boot messages aren't listed in /var/log/syslog or /var/log/dmesg then they aren't captured anywhere. check dmesg, and if that doesn't contain the errors, take a screenshot (with a digital camera) and transcribe the errors from that. –  quack quixote Mar 18 '10 at 14:48
    
Thank you ~quack, great idea, I just added the screen photo. I can fetch more information from the machine if necessary. –  Glen S. Dalton Mar 18 '10 at 19:09
add comment

1 Answer

up vote 0 down vote accepted

How about passing noresume to the kernel via grub? You could also try using a bootable Linux disk to run mkswap on the swap partition to wipe the recovery image flag there (note that you will need to change /etc/fstab after this, I can give further instructions regarding this if needed).

share|improve this answer
    
The best would be to add noresume to the kernel options. I want to stop this forever. Resuming is not neccesary on this machine. Maybe you can help changing the kernel options, I will post more info to the question now. –  Glen S. Dalton Mar 18 '10 at 19:39
    
I accepted this because it answers my question. But my grub still boots without the "noresume" –  Glen S. Dalton Mar 18 '10 at 20:07
    
You need to add the noresume to the "kernel" line, not the "title" line. All the title line does is display itself on the menu, it has no effect on the operation of the system. The kernel line is what actually matters; try changing number after "root=UUID=" to see what I mean (don't actually do this, it will refuse to boot until you change it back to what it was). –  marcusw Mar 19 '10 at 15:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.