Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Firefox won't start when I click on the icon.

Windows Vista, FF3.5.1. I normally am a laggard when it comes to deploying new stuff, but FF3.1 was hanging, like everyday. So I "upgraded" to FF 3.5.1, and now firefox won't start up. I see the firefox.exe process in Task Manager, but it never shows a UI.

I perused the net and saw a bunch of other people had this problem, going back to FF3.0 days, but the cause is not clear, and there's lots of guessing in all the discussion.

Anyone have a definitive workaround or avoidance for this?

ANSWER: I hadn't rebooted in a month or so, but installed some Windows Updates that required it. After the reboot FF 3.5.1 started up fine.

share|improve this question

migrated from Jul 24 '09 at 12:33

This question came from our site for professional and enthusiast programmers.

I would add this as an EDIT but don't have access. I rebooted the machine and afterwards, FF was able to start. – Cheeso Jul 27 '09 at 19:31
Guys i have the same problem. I have firefox 3 installed and i also have a portable firefox 3.5.1 installed both are not working horribly. Even after killing the processes it FF refuses to load. – Rishi Jul 30 '09 at 20:35
I rebooted, and FF3.5.1 started up fine, no re-install necessary. – Cheeso Aug 1 '09 at 18:51

The list of hints here is not helping.

I've uninstalled and re-installed FF3.5.1. No joy.

share|improve this answer
E-mail to see if they can link this question to your account. – ChrisF Jul 24 '09 at 12:59
Uninstalling doesn't always delete your profile, which might have something set in it which is incompatible with 3.5. – dlamblin Jul 27 '09 at 19:14
yeap, I removed the profile and profile directory, too, prior to rebooting. Obviously there was something I missed. Anyway, it's done now. – Cheeso Jul 27 '09 at 19:29

Try right-clicking the Firefox icon, then choose Firefox Safe Mode. You should get a Firefox Safe Mode dialog with a bunch of checkboxes. Don't tick any of them and click the Continue in Safe Mode button.

Does FF start and run correctly? If so, then there's a problem with one of your extensions or some other aspect of your config.

Now close FF again and re-open the Safe Mode dialog. Check the disable all add-ons checkbox which will permanently disable them. If Firefox now starts, you know it's an extension causing problems. Restart Firefox normally and re-enable the add-ons one by one. If you come across one that makes your browser unstable, either uninstall it or leave it disabled.

If you still have problems, go through each of the remaining checkboxes to reset the various other aspects of your Firefox config.

If you still have no luck, try deleting your profile or creating a new one.

Or you could try installing a portable version of Firefox somewhere other than your currently installed copy. It'll install and operate completely independently of your current, broken version.

share|improve this answer
I tried Safe Mode - same result. I trried deleting the profile. Same result. Firefox starts but remains invisible. – Cheeso Jul 25 '09 at 1:07
Try the portable version and let us know the results. – setatakahashi Jul 25 '09 at 7:39
up vote 1 down vote accepted

I finally rebooted Windows - necessary after installing other updates from Microsoft, and then FF3.5.1 was able to start. I didn't do anything besides just a simple restart, and then click on the FF icon.

share|improve this answer

I am experience the same issue as Cheeso (firefox does not start but I can see a firefox process running in the task manager). A difference for me is that rebooting windows does not help. Also, after this happens to firefox a right click on the windows taskbar start icon causes the windows task bar (windows explorer) to become unresponsive. Killing the firefox process does not recover windows explorer.

share|improve this answer
I fixed this issue by starting in safe mode and specifying, in addition to disabling add-ons (my first try), also reseting toolbars and controls. I did have some pdf files displayed in my list of open url's. – Jeffrey Hill Jan 4 '10 at 18:25

I've had this issue a couple times before. Typically when firefox.exe encounters an issue and closes the browser, but continues to run. At times I'll have to CTRL+ALT+DEL and end the firefox processes manually. Once I've done this (be sure to 'end' all instances of firefox.exe) I can then start firefox back up.

share|improve this answer
I had used Task Manager to close all firefox.exe processes. That wasn't the problem either. Good suggestion though, you're absolutely right that this can cause a problem. – Cheeso Jul 27 '09 at 20:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.